Pages: [1]   Go Down
Author Topic: Programmer is not responding  (Read 1038 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello.

I have made my own Arduino Duemilanove with Atmega168. When I click on the “Upload to I/O Board” button in the Arduino IDE I'm getting an error:

Binary sketch size: 976 bytes (of a 14336 byte maximum)

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

Operating system is Mac OS X. I tried all driver versions but I'm still getting the same error. I think board and serial port is selected right.
But on Windows XP, my Arduino works perfect. Windows is installed on Mac with Parallels.

I think its software problem.  What I'm doing wrong?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Any suggestions?
Logged

0
Offline Offline
God Member
*****
Karma: 1
Posts: 588
LumiNet rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

no idea. Check if it works on a windows machine or if the board is damaged.

How did you put the bootloader to the Atmega168 of your own Arduino?
Logged


0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

On PC with Windows XP the Arduino works perfect. On Mac with Windows XP it works perfect too. But on Mac with Mac OS X Leopard the Arduino doesn't work. When I click on upload button RX LED flashes few times and I get that error.

The bootloader is burnt with USB Tiny ISP through the Arduino IDE.
Logged

0
Offline Offline
God Member
*****
Karma: 1
Posts: 588
LumiNet rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I don't like to use Arduino with Mac OS because the FTDI drivers "are not good".
Maybe try to reinstall the drivers (uninstall them and then reinstall them)...
I can upload sketches via Arduino IDE on Leopard, so at least it is possible (using Arduino 0014).
Logged


0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I tried to reinstall drivers; also I tried other versions of Arduino IDE. I think there is only one way out of a situation – reinstall Mac OS X  :-/
Logged

Bristol, UK
Offline Offline
Edison Member
*
Karma: 1
Posts: 1197
Exhibitor at UK Maker Faire
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Did you select the proper type of Arduino from the Tools > Boards menu, when running on the native MacOS?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes, I selected "Arduino Diecimila or Duemilanove w/ ATmega168". Also I have tried all other types.
When I click on upload button, RX led flashes like on windows xp without ATmega168 chip. It seems that Arduino IDE can't see ATmega168 chip.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I give up. Nothing works. smiley-sad
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It still doesn't work. That's what I see, when I have enabled upload.verbose in Arduino preferences file.


Code:
Binary sketch size: 896 bytes (of a 14336 byte maximum)
hardware/tools/avr/bin/avrdude -Chardware/tools/avr/etc/avrdude.conf -v -v -v -v -pm168 -cstk500v1 -P/dev/tty.usbserial-A80083bt -b19200 -D -Uflash:w:/Users/ernis/Desktop/arduino-0016/examples/Digital/Blink/applet/Blink.hex:i


avrdude: Version 5.4-arduino, compiled on Oct  9 2007 at 11:20:31
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         System wide configuration file is "hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/ernis/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port            : /dev/tty.usbserial-A80083bt
         Using Programmer      : stk500v1
         Overriding Baud Rate  : 19200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding
avrdude: Send: Q [51]   [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding
« Last Edit: June 08, 2009, 05:28:56 am by Iernius » Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 11
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Try pressing the reset button on the board a second or so before - or just at the same time as - pressing the upload button in the IDE.  The board should reset automatically, but maybe it's not for some reason.
Logged

London, England
Offline Offline
Edison Member
*
Karma: 4
Posts: 1026
Go! Go! Arduinoooo !!!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I use a Mac and my Arduino works fine.
Logged

Pages: [1]   Go Up
Jump to: