Go Down

Topic: Arduino on Linux (Read 28 times) previous topic - next topic

madworm

ok.

- open a console in X
- type:
Code: [Select]
su
- enter the root password
- type:
Code: [Select]
yast2
- start the module for installation sources
- make sure these repositories are added and active:
Code: [Select]
http://download.opensuse.org/distribution/10.3/repo/oss/
http://download.opensuse.org/distribution/10.3/repo/non-oss/
http://download.opensuse.org/update/10.3/

- start the software installer module
- in the search field type AVR and press the search button
- select these packages: avrdude, avr-libc, cross-avr-binutils, cross-avr-gcc
- press accept
- yast2 will download and install the stuff
- start the user/group manager module
- edit the users who need to use the arduino software
- select the group 'UUCP' in the group membership tab. this will grant access to the usb port (/dev/ttyUSB*) and press OK/FINISH
- quit yast2
- in the console type:
Code: [Select]
find /opt/cross/bin/ -iname "avr*" -exec ln -s -t /usr/local/bin/ {} \;
- close the root console
- RESTART X (logoff/logon)
- as a normal user, open a console window
- extract arduino-0012-linux.tgz to the desired folder
- change to that directory
- type:
Code: [Select]
./arduino
- the IDE should start.
• Upload doesn't work? Do a loop-back test.
• There's absolutely NO excuse for not having an ISP!
• Your AVR needs a brain surgery? Use the online FUSE calculator.
My projects: RGB LED matrix, RGB LED ring, various ATtiny gadgets...
• Microsoft is not the answer. It is the question, and the answer is NO!

Jawa_Sparky

Thank you so much - I'll give it a shot

Jawa_Sparky

#52
Jan 02, 2009, 05:25 pm Last Edit: Jan 02, 2009, 05:27 pm by JawaSparky Reason: 1
madworm,

Thank you so much for your help!!

I ended up getting a DVDROM for $10 for the local computer parts store so I could load the full version had everything going fine except I could not find the repositories you mentioned:

Code: [Select]
http://download.opensuse.org/distribution/10.3/repo/oss/
http://download.opensuse.org/distribution/10.3/repo/non-oss/
http://download.opensuse.org/update/10.3/


Then I noticed that those looked like websites.  Lacking a wireless card I hauled the machine upstairs and plugged it straight in to the router, reinstalled the software and there it was (I ended up installing the 11.0 version).  The finding of the AVR packages was as simple as you said!

I did notice that I have to log into the terminal with "su" to have full access.  But maybe that is something for later.  

I found that running Arduino with Linux is actually easier to configure than in windows since the port setting actually says "usb":D

Again thank you for your help and time.

Sparky

E-Vampire

Hi everyone,
i have a problem with the arduino ide on archlinux. It works perfectly except that it doesn't upload the code to the board. The system correctly create a symlink in /dev/ttyUSB0 to /dev/tts/USB0, so the problem is not ftdi_sio, all the modules needed for connecting arduino are loaded. It give me always "/dev/tts/USB0 not found, have you selected the right port from Tools -> Serial port?". I know the file to exists, and Tools -> Serial port is grayed out, i can't select the port from there. I changed the voice on .arduino/preferences.txt. I tryed the following:

1) Changing RXTXcomm.jar and rxtxSerial.so in the arduino folder with the one's downloaded from rxtx.org

2) Removing RXTXcomm.jar and rxtxSerial.so and installing them system wide (yes, is almost the same as before, but I'm trying everything -_-)

3) chmod 666 on /dev/tts/USB0. Still not working.

4) chown myuser /dev/tts/USB0.

5) adding my user to groups uucp, tty and lock. Still nothing.

Even launching the ide as root doesn't make the things work as they should.

Do you have any clue?

Thanks.

wayoda

Hi,
I'm not sure if the RXTX-lib can deal with symbolic links to devices. Tried this briefly, didn't work.
Is there a reason archlinux creates the device-file as /dev/tts/USB0? Sounds very strange to me....

Eberhard

Go Up