Go Down

Topic: Problem trying to programm ATTiny84A  (Read 515 times) previous topic - next topic

ArduinoJ4ck

May 16, 2017, 10:33 pm Last Edit: May 16, 2017, 11:07 pm by ArduinoJ4ck
Hey guys i´ve ben trying all day to upload sketches to my ATTiny84A. I tried it with this Tutorial but im guessing it´s diffrent with a Mega 2560 right? I couldn´t find any clear instructions on this.
Error Code :avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.
Please help me

DrAzzy

You've given no information about what tutorial you're using or what problem you're having. We can't help if you don't tell us anything.
ATtiny core for 841+1634+828 and x313/x4/x5/x61/x7/x8 series Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts (some assembled), mosfets and awesome prototyping board in my store http://tindie.com/stores/DrAzzy

ArduinoJ4ck


DrAzzy

You have not described your problem - but that tutorial is ancient, and the requirements of boards.txt have changed since then; it will not work on recent versions of the IDE.

Why are you going to all that work instead of using a third party board package that someone else has prepared, like my ATTinyCore? It should work right out of the box without you having to go modifying files.

https://github.com/SpenceKonde/ATTinyCore
ATtiny core for 841+1634+828 and x313/x4/x5/x61/x7/x8 series Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts (some assembled), mosfets and awesome prototyping board in my store http://tindie.com/stores/DrAzzy

ArduinoJ4ck

#4
May 17, 2017, 06:40 pm Last Edit: May 17, 2017, 06:53 pm by ArduinoJ4ck
Thanks man thats a huge step forward. I did the Wiring as advertised in the Thread but it´s only described for VCC and GND or did is miss something ? Maybe it´s this graphic but i can´t understand it Graphic

Thanks for ur Help ;)

ArduinoJ4ck

#5
May 17, 2017, 06:58 pm Last Edit: May 17, 2017, 07:09 pm by ArduinoJ4ck
I did like displayed in the Graphic but it gives me this error
The Error Code now changed to
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x03
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xe0
Problem beim Hochladen auf das Board. Hilfestellung dazu unter http://www.arduino.cc/en/Guide/Troubleshooting#upload.

ArduinoJ4ck

Hey Guys i tried everything i could find maybe my ATTIny is broken ? Can u please help me?
Below is the Error Code

Code: [Select]
Arduino: 1.8.2 (Windows 10), Board: "ATtiny x4 series, ATtiny84, 1 MHz (internal), B.O.D. Disabled, Counterclockwise (like ATTinyCore)"

Der Sketch verwendet 832 Bytes (10%) des Programmspeicherplatzes. Das Maximum sind 8192 Bytes.
Globale Variablen verwenden 9 Bytes (1%) des dynamischen Speichers, 503 Bytes für lokale Variablen verbleiben. Das Maximum sind 512 Bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -pattiny84 -cstk500v1 -PCOM9 -b19200 -Uflash:w:C:\Users\JAKOBH~1\AppData\Local\Temp\arduino_build_449009/Blink.ino.hex:i

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:00:53
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM9
         Using Programmer              : stk500v1
         Overriding Baud Rate          : 19200
         AVR Part                      : ATtiny84
         Chip Erase delay              : 4500 us
         PAGEL                         : P00
         BS2                           : P00
         RESET disposition             : possible i/o
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65     6     4    0 no        512    4      0  4000  4500 0xff 0xff
           flash         65     6    32    0 yes      8192   64    128  4500  4500 0xff 0xff
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00
           lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
           lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
           hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
           efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00

         Programmer Type : STK500
         Description     : Atmel STK500 Version 1.x firmware
         Hardware Version: 2
         Firmware Version: 1.18
         Topcard         : Unknown
         Vtarget         : 0.0 V
         Varef           : 0.0 V
         Oscillator      : Off
         SCK period      : 0.1 us

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.02s

avrdude: Device signature = 0x000000 (retrying)

Reading | ################################################## | 100% 0.02s

avrdude: Device signature = 0x000000 (retrying)

Beim Hochladen des Sketches ist ein Fehler aufgetreten
Reading | ################################################## | 100% 0.02s

avrdude: Device signature = 0x000000
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.


avrdude done.  Thank you.

Dieser Bericht wäre detaillierter, wenn die Option
"Ausführliche Ausgabe während der Kompilierung"
in Datei -> Voreinstellungen aktiviert wäre.

Sig reading all 0's is 99% of the time either wiring problem, or you've set the chip to use an external crystal or clock source, but one isn't connected.

glatteis

I did like displayed in the Graphic but it gives me this error
The Error Code now changed to
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x03
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xe0
Problem beim Hochladen auf das Board. Hilfestellung dazu unter http://www.arduino.cc/en/Guide/Troubleshooting#upload.

I did like displayed in the Graphic but it gives me this error
The Error Code now changed to
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x03
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xe0
Problem beim Hochladen auf das Board. Hilfestellung dazu unter http://www.arduino.cc/en/Guide/Troubleshooting#upload.

I'm experiencing exactly the same error with my ATTiny. I solved it yesterday, I explained how here: https://forum.arduino.cc/index.php?topic=477761.15

but I have it again today, woth exactly the same wiring and exactly the same method of programming it. Apparently it's just luck if it works.

ArduinoJ4ck

I'm experiencing exactly the same error with my ATTiny. I solved it yesterday, I explained how here: https://forum.arduino.cc/index.php?topic=477761.15

but I have it again today, woth exactly the same wiring and exactly the same method of programming it. Apparently it's just luck if it works.
Maaan ur a god! It worked just perfectly ur description was as easy as walking forward is.. Love it.
Hope you have luck with ur one 2 :)

ArduinoJ4ck

Is it normal that the Attiny gets hot he´s about 100 degrees :(...

glatteis

Is it normal that the Attiny gets hot he´s about 100 degrees :(...
Mine did that too, you're probably putting too much current through it. Try using a resistor.

ArduinoJ4ck

Should i put the Resistor in series with + ? ANd which kind of resitor ? Im powering it with a 5v powerbank i measured it and it´s 5v....

glatteis

Should i put the Resistor in series with + ? ANd which kind of resitor ? Im powering it with a 5v powerbank i measured it and it´s 5v....

The current shouldn't exceed 40mA. I hope someone is an expert on resistors but as

R = U / I

you should measure your current and put a light resistor between + and VCC so that your current is under 40mA. The ATTiny works with very small currents though so just put any resistor in and try with that.

DrAzzy

Is it normal that the Attiny gets hot he´s about 100 degrees :(...
No, absolutely not.  you've connected something very wrong if it is...

Which of course would explain the difficulty in programming it. You may have damaged the chip at this point.
ATtiny core for 841+1634+828 and x313/x4/x5/x61/x7/x8 series Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts (some assembled), mosfets and awesome prototyping board in my store http://tindie.com/stores/DrAzzy

Go Up