Go Down

Topic: Can't start .exe: "The memory could not be 'read' (Read 474 times) previous topic - next topic

Iquaba

Jun 02, 2009, 08:15 pm Last Edit: Jun 02, 2009, 09:59 pm by Iquaba Reason: 1
Hey all,

After using arduino-0015 fine for a while all of a sudden I got this error after trying to start arduino.exe:

"The instruction at '0x7c9369ea' referenced memory at '0xfffffffffff'. The memory could not be 'read' Click ok to terminate the program or Cancel to debug the program."

And it never starts.  I've tried re-downloading, etc. but it still won't work.  Opening it with run.exe works though.

Thanks for any help!

madworm

• Upload doesn't work? Do a loop-back test.
• There's absolutely NO excuse for not having an ISP!
• Your AVR needs a brain surgery? Use the online FUSE calculator.
My projects: RGB LED matrix, RGB LED ring, various ATtiny gadgets...
• Microsoft is not the answer. It is the question, and the answer is NO!


Ron C

I am getting the same error except memory referenced at 0x00000000. (did it on version 015 and 016)

I onlt happens if I double-click a .pde file and only on certain ones - on others it opens the IDE fine. If I runn the program directly, it also runs with no problem.

Curious!?!?  I wonder if it depends on what libraries are included

The Clever Monkey

#4
Jun 05, 2009, 11:09 pm Last Edit: Jun 05, 2009, 11:44 pm by clvrmnky Reason: 1
If Dr. Watson still exists for Win32 get trace of the failure.  This is, essentially, a protection fault of some kind.  Some native component of the software is stepping on memory that is not valid.  It could be anything, really.

Just read your last.  I wonder if it is trying to compile some of the libs necessary for those sketches.
I yield() for co-routines.

bGatti

Same problem:
version 10, 11, 16
XP, Vista, Several Machines(3)

Go Up