Go Down

Topic: Cant upload sketches/flash chip (Read 560 times) previous topic - next topic


Hi everyone

I started a thread a few days ago about how my Arduino Duemilanove 328 won't upload any sketches, giving the error:

avrdude: verification error, first mismatch at byte 0x0042
        0x79 != 0xa4
avrdude: verification error; content mismatch

I was advised to try reflashing the chip.  I might be wrong but I assumed this meant reburning the bootloader.

Following the instructions on http://arduino.cc/en/Hacking/ParallelProgrammer, I built a parallel programmer using a printer connection and parts from a USB internal connector from a PC (the bit that goes to the motherboard).

I tested all the pins with a multimeter, all of them checked out, I also removed all other pins except the ones that were needed so I am sure nothing is shorting out.  But for some reason, the programmer doesn't work :(.

Whenever I try to use it I get this error: "Wrong microcontroller. Are you sure you entered proper board under tools?".

I am certain the correct board is selected.  I also tried changing the preferences.txt so that it will use the parallel to upload sketches, but that didn't work either.

I have tried multiple computers, new drivers, different leads, and now the parallel programmer, nothing works :(

Is there a chance that something other than the ATMega328 is faulty?  That might explain why I can't do anything to fix it...

I don't mind ordering a new atmega328 chip, but I wanted to make sure that was likely to be the fault first :P

Anyway, I have a few awesome projects in mind including some car displays interfaced with GPS, which will also be able to talk with you via voice recognition (essentially night rider inside a peugeot 106 xD) and a voice controlled robot that can fetch data from the internet (emails, weather) etc.  If anybody here figures out what's wrong with my Arduino, then I will be sure to send pics and info to you first when I get them going =D.  

Plus I will send a gift wrapped cookie to you.  Nobody can turn that down :)


Do your onboard 13-pin LED blinks?

Anyway with those problems, if you bought it a very short time ago and couldn't get it work, ask your shop for a replacement chip!


Aug 26, 2009, 10:28 pm Last Edit: Aug 26, 2009, 10:33 pm by Chris17 Reason: 1
The onboard pin 13 pin blinks just like the "Blink" sketch does, and when I try to upload the RX and TX lights flash just like they should.

About getting a new chip... i'll contact the website and ask them, I hope they won't need me to send the faulty one back though, would be cheaper to order a new one :P

Thanks for the reply btw, was pretty quick :)


Ok no, they won't replace it they just told me to buy a new one <_<

Any other ideas?  :-?

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131