Pages: [1]   Go Down
Author Topic: please Help!!  (Read 589 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have been asking the forum for help and have gotten nothing.  I am new to this and without help I am doomed to fail.  I had the freeduino v2.0 and thinking I screwed it up I purchased the duemilanove and still nothing.  I am running windows XP.  I have read through the troubleshooting a hundred times and I have checked everything it tells me to check.  The message I get when trying to upload "blink" is
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I have selected the proper serial port and downloaded the proper driver software.  I would seriously appreciate someones help.  PLEASE HELP ME!!!
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 81
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi

did you select the correct device within the IDE?

cheers
Peter
Logged

Erkläre es mir, ich werde es vergessen. Zeige es mir, ich werde es vielleicht behalten. Lass es mich tun, und ich werde es können. Indisches

0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I'm having the same problem with an Arduino single sided board in Windows XP.
It has a serial interface and is connected via a prolific usb/serial converter.

The Arduino Duemilanove I have does not have this problem it works fine.

I tried the Arduino ssb under UBUNTU and it works fine under that OS.

So looks like it is a Windows problem.
Wonder if Windows and UBUNTU use the same Java version :-/.
In Windows I use Sun Java 1.6.0_15.

Can't help you yet. But your not alone. Will keep you posted..
Logged

London, England
Offline Offline
Edison Member
*
Karma: 4
Posts: 1026
Go! Go! Arduinoooo !!!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

That error is commonly obtained simply by choosing the incorrect board from the IDE. Check the chip on the board and make sure you have the correct one selected in the IDE.
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 81
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

that's what I meant...
Logged

Erkläre es mir, ich werde es vergessen. Zeige es mir, ich werde es vielleicht behalten. Lass es mich tun, und ich werde es können. Indisches

0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

Tried my Arduino ssb with the same driver in Windows 7 and the board worked fine. Selected the same board (328p) the IDE under Windows XP and Windows 7.

Now it looks even more like a Windows XP problem.


Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

Wrote a little command line program to test communications with de Aduino ssb board.

Here is the output:


As you can see there is a correct response from the board.

Looks like a avrdude problem now.

Will look in to that later. Have to do some tasks first.

Here http://www.tweebs.nl/ladyada/Serialtest.exe is the test program if you want to test connectivity (for Windows only).
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

After several test it's still not working with my home hardware.
The Windows 7 is a 32 bits system at work with different hardware.
Same Prolific driver...

After installing Windows 7 64 bit RC at home I encountered the same problem.

It concluded its a combination of the PC hardware I have and the way the prolific driver functions and the single sided serial board.

After fiddling with the avrdude configuration, which did not help either,  I decided to write my own uploader that replaces avrdude.

All works fine now in Windows XP with my Arduinoi 2000 and the ssb.

And, yes, you have to select the correct board and port.
If you don't you'll get the same error. smiley-wink
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Well finally solved the problem by installing a new avrdude. :-?
The version in the Arduino IDE was from 2008.
The latest avrdude version is 20090313.

Hopefully the will replace avrdude by the last version in the next release of the Arduino IDE.



Logged

Pages: [1]   Go Up
Jump to: