Go Down

Topic: [resolved]avrdude (Read 959 times) previous topic - next topic

linedubeth

Sep 26, 2009, 02:20 am Last Edit: Sep 26, 2009, 11:43 am by linedubeth Reason: 1
Hello,

i use ubuntu 8.04  i've reinstalled a system
i upgrade with 8.10
i have a duelimove atmega328
i have not inserted the led in
i have change the 19200 bds in arduino--017 boards.txt
i have the serialport /dev/ttyUSB0  in IDE arduino
iverify with

gg@gg-desktop:~$ ls /dev/ttyUSB*
/dev/ttyUSB0
gg@gg-desktop:~$





my message with blink is

Experimental:  JNI_OnLoad called.
Stable Library
=========================================
Native lib Version = RXTX-2.1-7
Java lib Version   = RXTX-2.1-7

o: In function `main':
undefined reference to `setup'Bad error line: -1










Binary sketch size: 896 bytes (of a 30720 byte maximum)
Binary sketch size: 896 bytes (of a 30720 byte maximum)

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding



my lsusb

lsusb
Bus 005 Device 003: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


mydmesg |tail

gg@gg-desktop:~$ dmesg|tail
[  997.518801] r8169: eth0: link down
[ 1003.226637] r8169: eth0: link up
[ 1772.379152] ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from ttyUSB0
[ 1967.002989] r8169: eth0: link down
[ 1989.032032] usb 5-1: new full speed USB device using uhci_hcd and address 3
[ 1989.256523] usb 5-1: configuration #1 chosen from 1 choice
[ 1989.259151] ftdi_sio 5-1:1.0: FTDI USB Serial Device converter detected
[ 1989.259776] ftdi_sio: Detected FT232RL
[ 1989.260244] usb 5-1: FTDI USB Serial Device converter now attached to ttyUSB0
[ 2158.791834] r8169: eth0: link up


my avr-gcc
avr-gcc -v
Using built-in specs.
Target: avr
Configured with: ../src/configure -v --enable-languages=c,c++ --prefix=/usr/lib --infodir=/usr/share/info --mandir=/usr/share/man --bindir=/usr/bin --libexecdir=/usr/lib --libdir=/usr/lib --enable-shared --with-system-zlib --enable-long-long --enable-nls --without-included-gettext --disable-checking --disable-libssp --build=i486-linux-gnu --host=i486-linux-gnu --target=avr
Thread model: single
gcc version 4.3.2 (GCC)


my avrdude
avrdude version 5.8, URL: <http://savannah.nongnu.org/projects/avrdude/>



i have recompiled

my version of java

java - l'état est auto.
le lien pointe actuellement sur /usr/lib/jvm/java-6-sun/jre/bin/java
/usr/lib/jvm/java-6-sun/jre/bin/java - priorité 63
lien secondaire java.1.gz : /usr/lib/jvm/java-6-sun/jre/man/man1/java.1.gz
La « meilleure » version actuelle est /usr/lib/jvm/java-6-sun/jre/bin/java.


i am desesperate

could you help me

thanks à lot

wayoda

Hi
Quote

i have change the 19200 bds in arduino--017 boards.txt

You can't do that!
There is nothing in this file which should be changed by the user.

Put it back to 57600bds and try again...

Eberhard

linedubeth

thanks

it's run actually.

i continue  :)

tytower

Are the speeds then in /hardware/boards.txt  the maximum speeds for those boards?

linedubeth

it's run fine at 57600

wayoda

Quote

Are the speeds then in /hardware/boards.txt  the maximum speeds for those boards?

No, these are the speed-setting for the bootloaders on the boards. If you change on of these, the upload speed used by the IDE will be different from (hardcoded) speed on the ATmega-bootloader which prevents successful uploading.

In your Sketches you are free to use any other speed you need. The maximum speed for the boards depends on so many different environmental and hardware factors that its hard to say what the highest possible speed might be.

Eberhard

Go Up