Pages: [1]   Go Down
Author Topic: 0017 in Vista?  (Read 754 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 16
Arduino rules
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I just upgraded to IDE 0017 on my Vista system. If I run things in Administrator mode, all is well. But if I attempt to start arduino.exe with normal privs for my account, it claims that the sketchbook folder no longer exists (Which isn't true). It then terminates by saying that "Arduino could not run because it could not create a new folder to store your sketchbook. "

But what is odd is that I have full rights to the path the sketchbook folder is located in. ("D:\arduino\sketchbook\")

Suggestions? I'd prefer not to have to run this with elevated privileges.

-Rich



Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hmm, see: http://dev.processing.org/bugs/show_bug.cgi?id=1016 for some tips. In particular:

"The location is pointed to by the Registry key
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell
Folders\AppData

Please make sure the directory location stored at that registry key is
writable. "
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 16
Arduino rules
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for that tip! I'll check it out tomorrow morning, and let everyone here know if that fixed it.
 smiley
Logged

Pages: [1]   Go Up
Jump to: