Go Down

Topic: avrdude trouble (Read 423 times) previous topic - next topic

mmormota

I tried uploading .hex code to the Ardupilot board using avrdude but my efforts failed, probably because of my incorrect parameter settings.

The compile-upload process using the Arduino0017 studio is working very well -I just like to upload hex files developed by a third party compiler.
As far as I know Arduino uses avrdude as well, so it can be done with avrdude - just I am not smart enough.

The Ardupilot board is similar to the Duemilanove with ATMega328p.

The avrdude.exe and avrdude.conf file I tried was the one in the arduino0017 studio.
The board is the new red Ardupilot, the uC is ATMega328p.
The cable is the diydrones ftdi one.

Could you please help me with a proper upload.bat file for avrdude (or any other program) that's actually working with the bootloader?


pekkaa

Did you set the DTR-signal before uploading? It is needed to trigger auto reset. The following works on Linux:

Code: [Select]

perl -MDevice::SerialPort -e 'Device::SerialPort->new("/dev/ttyUSB0")->pulse_dtr_on(1000)'; \
./hardware/tools/avrdude -Chardware/tools/avrdude.conf -q -q -pm328p -cstk500v1 -P/dev/ttyUSB0 -b57600 -D -Uflash:w:/home/pekka/sketchbook/Blink2/applet/Blink2.hex;




Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy