Pages: [1]   Go Down
Author Topic: 017 visual elements duplicated(tabs,menus,status)  (Read 1287 times)
0 Members and 1 Guest are viewing this topic.
ottawa, canada
Offline Offline
God Member
*****
Karma: 6
Posts: 991
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I see multiple copies of the toolbar and tab lines at the top of the ide window and the status line at the bottom.

I'm running IDE version 017 on vista with java 1.6.0_15.

Do other people still have this issue?
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 208
Posts: 12932
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I have...

Vista Business service pack 1
Java 1.6.0_15-b03
Arduino 0015

No problems here.
Logged

ottawa, canada
Offline Offline
God Member
*****
Karma: 6
Posts: 991
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

only happens at IDE 017.  I just can't believe it's been outstanding for months.
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

This is caused by a bug in the Java version that comes with Arduino 0017, and only happens on certain computers.  You should be able to fix it by downloading the latest version of Java, and replacing the one in the Arduino application directory.
Logged

ottawa, canada
Offline Offline
God Member
*****
Karma: 6
Posts: 991
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

thank you very much.  

Only took me an hour to figure out where java lives and how to replace it.  Java version management is pants.  

There seem to be several copies of java on each windows machine in my house.
Logged

ottawa, canada
Offline Offline
God Member
*****
Karma: 6
Posts: 991
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

and now the darned thing won't start - just a glimpse of the splash screen. grrrr.

restoring the java directory gets it running again (with the duplicated visuals).  Enough diddling java, I just wanna code.  Maybe release 18...
« Last Edit: October 18, 2009, 07:13:51 pm by bill2009 » Logged

ottawa, canada
Offline Offline
God Member
*****
Karma: 6
Posts: 991
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

got a new java release today, once again I copied the jre directory into the arduino/java library and once again it's working - for now...

I live in hope.
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 77
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have this problem with:

Windows Home Premium 32-bit
Java 6 update 11
Arduino 0017

I have installed Runtime 6 update 17, and rebooted, but it did not fix the issue.

You mentioned replacing files in the Arduino installation directory-- what files do I replace, and where do I get them?

smiley-sad
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 77
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

*Update*

Okay, I figured it out and it's working, here are step-by-step instructions for others with the same problem:

Download and install Java Runtime 6 update 17 (JRE)
http://java.sun.com/javase/downloads/index.jsp
it's about halfway down the page.

Go to
.../Program Files/Java/jre6/
and copy all the files within that directory

Go to
.../Arduino-0017/java/
and delete all the files within, then paste the files you just copied.

Fixed it for me...
Logged

ottawa, canada
Offline Offline
God Member
*****
Karma: 6
Posts: 991
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

good explanation - thanks.

Did you try just deleting the java directory to see if it would use the newly installed version?  There must be some way to do that.
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 50
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

If you have Sun's JRE installed, you can just delete the "java" folder in the Arduino software (and get 80MB of space back).  Arduino is able to find the installed JRE.  I can verify that it works on my system (Vista Ultimate x64, JRE 6u15).  
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks this worked for me with RC Windows 7 Ultimate.  I also tried to delete the java directory in the arduino-0017 and this caused the software to not run at all.  copied it back and it works like a charm.
Logged

Pages: [1]   Go Up
Jump to: