Go Down

Topic: Can't enter text in IDE at Debian Lenny Linux (Read 737 times) previous topic - next topic

Xarragon

Hello, I'm new to Arduino development and have gotten myself an Duemilanove and a shield to use for prototyping. I usually write code from scratch using my AVRISP och AVRICE but I figure I should try the native Arduino IDE just for giggles if nothing else.

Anyway, I have some trouble with the IDE. I simply can't enter any text into it except for pasting. I have installed the packages openjdk6-jre and librxtx-java and set up my CLASSPATH and JAVA_HOME. I have also selected the openjdk versions of java and javac with the Debian tools 'update-alternatives java/javac'.

I have installed the Arduino IDE into a directory in my $HOME, in /home/xarragon/programs/aurdino from which I execute it. I have not set up any extended privileges for it yet; is this needed for serial port access?

Any suggestions for what could be wrong? My system is an Intel P4 2.8 GHz, 1 Gb RAM running Debian Lenny I386 with kernel 2.6.26-2-686. OpenJDK Runtime Environment (build 1.6.0_0-b11), OpenJDK Client VM (build 1.6.0_0-b11, mixed mode, sharing). The Arduino IDE is version 0017.

Thanks for any help!

wayoda

Hi,
sorry but so far I had nothing but trouble with "openjdk6-jre".  
I suggest you use the jdk provided by Sun. This worked for me.
Eberhard
P.S. Do you know that you also need to install the "avr-libc" and "gcc-avr" packages to compile sketches?


Xarragon

Thanks for your reply wayoda. I agree that openjdk is pretty much useless. If you want anything to work you have to use the "evil" Sun open source version. Otherwise Eclipse and other just won't work. I originally had the Sun version installed, but since Arduino didn't work AND they recommended the openjdk packages on the website/wiki I tried them as well.

I did run a full system update though. It seems some of my packages were a bit outdated (including kernel). I then trew out all the openjdk packages along with configs (apt-get remove --purge) and rebooted the system.

After the reboot the Java binary wasn't in my $PATH, but that was easily fixed manually. I also setup my $CLASSPATH and $JAVA_HOME, but these didn't seem to affect the Arduino IDE much. I still can't enter text, and there are no warnings displayed in the terminal that I launch Arduino from.

There seems to be some issues with my Java installation, I can't start Eclipse either. I am looking into it.

Xarragon

Okay, Eclipse is back up and running. Seems I got hit by this dependency bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507536

Installing xulrunner-dev got Eclipse working again, and I can enter text in that IDE without a hitch. Arduino however, remains nonfunctional.

Xarragon

I just did a SVN checkout of revision 802, compiled it and executed it. It still won't work. This must be something specific to my installation it seems... I can't click any buttons or enter text in any boxes.

Xarragon

Well, I skipped Linux for now and installed the Arduino IDE onto my Windows XP installation instead. It worked wonders, albeit I was a bit shocked by the fact that the Windows version contains AN ENTIERE JAVA RUNTIME INSTALL? What the devil? That's like another 100 Mb of diskspace wasted. But at least my three servos are jazzing back and forth now, so I can build that laser cannon.

As for the Linux trouble I'll return later and figure out what's wrong. I'll also try it on another machine with a different distro.

Go Up