Go Down

Topic: serproxy - waiting for clients (Read 4 times) previous topic - next topic

Nilloc

I'm running into the same problem, and wonder if it has to do with the cfg file...

when i try telnet 127.0.0.1 5331 it says:

Trying 127.0.0.1...
Connected to localhost.
Escape Character is '^]'.
Connection closed by foreign host.


and in the window running serprozy i get: Failed to open comm port - connection refused

flash connects and says it's trying, but serproxy gives the same warning.

I'm on OS X and don't know how to determine what comm port it's on (in the config i have comm_ports=1), the serial port is /dev/cu.usbserial-A1015S9

heres the whole serproxy.cfg file

newlines_to_nils=true
comm_ports=1
#don't know how it determines this

comm_baud=19200
#matched in the pde on arduino
comm_databits=8
comm_parity=none

timeout=300

serial_device1=/dev/cu.usbserial-A1015S9
#name from the menu in the IDE

net_port1=5331
#5331 is arbitrary right?

mellis

Dave: that sounds like a config or networking problem.  Can you post your serproxy.cfg file?

Nilloc: make sure you quit any other program that might be accessing the serial port (e.g. the Arduino environment).  Also, make sure there aren't any funky characters in the name of the Arduino serial device by opening the preferences.txt file (in your Home directory/Library/Arduino) and looking for the device.

Nilloc

#7
Jun 08, 2007, 03:32 am Last Edit: Jun 08, 2007, 02:32 pm by Nilloc Reason: 1
thanks for the idea, but the preference file looks identical to my serproxy.cfg file
serial.port=/dev/tty.usbserial-A1015S9

i do have a weird character if i check on the device in the terminal i get:
crw-rw-rw-    1 root      wheel       9,  15 Jun  7 21:22 cu.usbserial-A10?15S9
crw-rw-rw-    1 root      wheel       9,  14 Jun  7 21:22 tty.usbserial-A10?15S9

I'm asuming that ? might be a problem, although the serial monitor in the IDE works fine.
Also I've made sure that all serial port using software is working still.

EDIT: so I was gonna make a symbolic link to the serial device (total shot in the dark but i'm new to this) and when i hit tab to auto complete the path to the cu. arduino, it auto completed with: /dev/cu.usbserial-A10^P15S9 but changing to that or using the symbolic link in the cfg didn't appear to change anything. Still refused connection.

mellis

That funky character is definitely a problem.  The symbolic link should work though.  What happened when you tried it?

jozero

#9
Jun 22, 2007, 01:29 am Last Edit: Jun 22, 2007, 01:30 am by jozero Reason: 1
Hello,

I am having the same issue.

- I can upload and run simple programs using ardino software
- I upload the Firmata firmware to the aurdino board.
- I quit the aurdina software

- I start serproxy, it says waiting for clients
- I try the ArduinoFF flash connection example. It says 'started connection', then immedatialy says 'stopped connection'
- serproxy always just says 'Failed to open comm port - connection refused'

- in the aurdino software it says its connecting to 'cu.usbserial-a1015ej', but in /dev/ it says 'cu.usbserial-A10?15EJ'. Trying either in the config doesnt work. I've tried connecting at the 115K baud rate and the 9600.

config file :
___
newlines_to_nils=false

# Comm ports used
comm_ports=1

# Serial devices
# Replace this with your Arduino port. Note that it starts with cu and not tty.  
serial_device1=/dev/cu.usbserial-A1015EJ

# Default settings
comm_baud=9600
comm_databits=8
comm_stopbits=1
comm_parity=none

# Idle time out in seconds
timeout=300

# Port 1 settings (ttyS0)
net_port1=5331
___

Any help appreciated. My firewall is off, its os x with 10.4.9 intel. I cannot telnet to it either, it says connection refused.

Go Up