Go Down

Topic: error burning bootloader: linux, usbtinyisp, 328 (Read 709 times) previous topic - next topic

michael shiloh

Working on the problem I had last week, where my Arduino Duemilanove with ATMEGA 328 seems to have a corrupted bootloader.

I have borrowed a USBTinyISP and am trying to reprogram the bootloader, but I get the following error:

USB read error: expected 4, got -1
USB read error: expected 4, got -1
avrdude: initialization failed, rc=-1
        Double check connections and try again, or use -F to override
        this check.

I have tried both allowing the USBTinyISP to power the Arduino, and also powering the Arduino externally, via USB.
I'm using Ubuntu Linux and version 15 of the Arduino IDE.

Any suggestions?

greyskale

I had this same issue until I ran Arduino as a superuser. Try sudo ./arduino
there are 10 types of people in this world, those who can read binary and those who can't.

Zoidie


Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy