Pages: [1]   Go Down
Author Topic: How to install arduino-IDE on openSUSE 11.2  (Read 1887 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 21
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This posting is originally part of the "error compling when uploading blinker"-thread.
 
Hi PaulS, Eberhard and the rest of the community,

the problems are solved, that means: My Arduino-Duemilanove is blinking with the 1/1-sec-cycle Smiley YEEEAAAAAAAAAAAAAAAAAHHHHHHHHH
After all the problems I had to get it run, it's worth to be shouted out, - loud and with the shown BB-fist  !!!!!

And here the promised step-by-step-installation-guide:

As I am an absolute Newbie and as I'm not sure if the installation will work on every SUSE11.2-System, I prefer to post it here, and not directly to the playground-site (as suggested by PaulS). If somebody is skilled enough to decide that this guide is worth to be posted as general-solution to the playground... don't hesitate to do so. smiley As a beginner I can't take the responsibility..

Pre-Story: Before getting the system run according to the following way, I tried to install it step by step according to the written solution of the playground-site. From the beginning this way to me seemed a little bit confusing and in deed I run into various problems with version-mismatches, warnings and error-messages. Furthermore, due to his experiences, an other user (David) told me not to install "this or this version". So I really got confused as well as the entire software-system on my computer  :-[. If somebody is interested in this odyssey:  search for forum-software-troubleshooting-Arduino-IDE on openSUSE 11.2.

After performing the following steps, you at least should be able to start the arduino-program, connect it to an atmega328p-Duemilanove-Board by USB and upload the "Blinker-Program"  on a 64-Bit openSUSE 11.2-System (intel-atom-dual-core). And this with only the standard-rxtx-mismatch-warning at program-start  smiley (up to now, I couldn't solve this, but according to David's words: that doesn't matter, the system will work properly anyway)

OK, let's go:

Preparation: In order not to run once-more into mismatches, I first uninstalled all the libraries and programs which I later had to  install again. I un-installed with yast: avr-libc, cross-avr-binutils, cross-avr-gcc, JRE and avrdude. I un-installed manually (deleted) the arduino-0018-IDE. At the end I had a virgin-like-system (according to the arduino-matter).

Step 0: Un-install everything as described above and add the following repository to Yast's repository management: http://download.opensuse.org/repositories/CrossToolchain:/avr/openSUSE_11.2

Step 1: Install with Yast: avrdude 5.10-256.1-x86_64

Step 2: Install with Yast: avr-libc 1.6.8-2.2-x86_64 (AVR-Arduino-version), with this, cross-avr-binutils 2.19.51-11.26.2 and cross-avr-gcc44 4.4.1_20090817-2.3.1 will be installed automatically in order to resolve dependencies.

Step 3: Install with Yast: JRE: java-1_6_0-openjdk Version: 1.6.0.0_b16-5.10.1-x86_64

Step 4: Add symlinks as described at the playground-page from a terminal-command-line with:  find /opt/cross/bin/ -iname "avr*" -exec ln -s -t /usr/local/bin/ {} \;

Step 5: Go to http://software.opensuse.org/search?baseproject=openSUSE%3A11.2&p=1&q=rx..., choose the third offer in the list (rxtx-java-geo-version) and install it with the One-Click-Installation-Button

Step 6: Use the Yast-User-Group-Management and ensure, that the arduino-user (you, or a guest) is member of the dialout and the uucp-groups.

Step 7: Go to http://arduino.cc/en/Main/Software, select Linux 64-bit and download the arduino-0018. Unpack it to your ~/bin directory (so I did..)

Step 8: Connect the Board with the USB-Cable to the first USB-Port of your Computer (so I did..)

Step 9: Start the arduino-0018 from the command-line by typing: /~/bin/arduino

Step10: Select the tools-serial-menu: The /dev/ttyUSB0 should be checked and not be greyed out.

Step11: Load the Blinker-Program from the File-Examples-Digital-Menu

Step12: Push the upload-button. Now the Program should be uploaded and started. The Pin13-LED will blink within 1-1 Sec-Cycle.

Congratulations... if it works.. if not ... Mh: Ask the experts (but not me smiley

Happy greetings from good old Germany (Ludwigshafen), Rafa
« Last Edit: March 07, 2010, 07:41:04 pm by elgitanito » Logged

Pages: [1]   Go Up
Jump to: