Go Down

Topic: Arduino Programming Environment Vanishes (Read 1 time) previous topic - next topic

ctdahle

I am working my way through the tutorials and having an odd problem. Beginning yesterday afternoon, the Arduino programming environment simply disappears for no apparent reason.

I'll be typing in code and suddenly the program just vanishes. It has also happened when I resize or move the Arduino program to a different part of the desktop, or when I click on the save or save as choices in the file menu.

Sometimes it happens as soon as I begin typing in the editing window, other times it happens when I try to save, but when it happens, it closes every sketch I have open on the desktop and all edits are lost.

I have begun clicking "Save" every time I edit a line, but this does not help when the act of clicking save closes the program!

I'm running Arduino on Ubuntu 9.10 (Karmic) and until yesterday there had been no problems since I began my Arduino adventure in mid March.

Imahilus

Did you update not long before this issue started to occur?
Might help in finding the root of the problem..

ctdahle

Thank you for replying.

I do run update manager weekly (on Thursdays) however, the Arduino environment was working properly on Friday and yesterday morning. The odd vanishing behavior began last night and continued this morning...

...but oddly, the problem has not recurred since I wrote the initial post in this thread (during which time I have written 3 sketches).

ctdahle

And now, it just happened three times in 10 minutes. Very strange behavior, almost like it is deliberately playing with me. It goes a couple of hours without shutting down, and then, about the time I decide that there is not a problem, it does it again.

Imahilus

Sounds like an old windows installation I used to have..
Not even a fresh install would fix it on that bucket  :-/

I'm clueless, sorry.

ctdahle

Thank you for the try anyway.

During the last upload of a sketch, I did notice that there was a lengthy list of Java errors appearing in the error window beneath the editing window.

Program crashed just as I was trying to copy the text to a place where I could print it out and study it. Despite the errors, the sketch did run properly.

ctdahle

Well, it's still doing it. Sometimes it shuts down in the background while I am doing something in another program, for example, I was clicking back and forth from the Arduino environment to a Firefox window this morning and Arduino blinked out while I was in the middle of reading something on the Arduino website.

I guess no one else is having this problem.

PaulS

I read this whole thread. I don't see anywhere where you mentions what operating system you are using, or which version of the IDE.

AWOL

"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

PaulS

At least I didn't day that I read all the way to the end of each post...

retrolefty

#10
May 10, 2010, 01:59 am Last Edit: May 10, 2010, 02:00 am by retrolefty Reason: 1
Quote
At least I didn't day that I read all the way to the end of each post...


Yea, but you sure seem to scrutinize some posts pretty closely. Ah the sweet smell of justice served.  ;D By the way I think day = say?

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1273081959/6#6

Lefty

ctdahle

I did say I was using Karmic (Ubuntu 9.10) in my first post.

True, I didn't mention that I am using Arduino 0018.

My board is a Duemilanove, but the problem occurs regardless of whether the board is plugged in.

mellis

ctdahle: what Java are you using?  In general, anything other than the Sun one usually has problems.

wayoda

Install the sun-java6-jre package and make it your default java runtime
Code: [Select]

sudo apt-get sun-java6-jre
sudo update-alternatives --config java

Eberhard

ctdahle

Thank you mellis and wayoda

First I checked my java version

Code: [Select]
ctdahle@ctdahle-laptop:~$ java -version
java version "1.6.0_0"
OpenJDK Runtime Environment (IcedTea6 1.6.1) (6b16-1.6.1-3ubuntu3)
OpenJDK Client VM (build 14.0-b16, mixed mode, sharing)


Which seems to NOT be Sun Java.

I tried to run the Java test at Sun's website, and saw no action, so then I tried to run the code wayoda posted

Code: [Select]
ctdahle@ctdahle-laptop:~$ sudo apt-get sun-java6-jre
[sudo] password for ctdahle:
E: Invalid operation sun-java6-jre
ctdahle@ctdahle-laptop:~$ sudo update-alternatives --config java
There is only one alternative in link group java: /usr/lib/jvm/java-6-openjdk/jre/bin/java
Nothing to configure.


It does make sense that Java is at the root of the problem. I was playing with ALICE for a while (also Java based), but it kept crashing and I wasn't finding it all that interesting, so I never chased down the problem.



Go Up