Go Down

Topic: Serial port 'COM19' already in use (Read 9 times) previous topic - next topic

wongster

Hi all,

I'm very new to this and have bought a Duemilanove a few days back.

Followed the instruction on arduino site and managed to upload the blinking led sketch. It works and continue to work since; the blinking won't stop even if I press the reset button.

I tried to upload another example but this time round, I was served with "Serial port 'COM19' already in use. Try quiting any programs that may be using it". I closed off any running programs and tried again. No luck.  Same message received.

I'm on Vista Home.

Any help would be appreciated.

Thanks.
Wongster

wongster

Anyone can help me with this?  or point me to a simple to understand post/site?  Very much appreciate if help can be rendered.

I'm sure no processes or programs are using com19 as I can see that it is not tagged with "in use".  Tried other ports without avail.  Tried doing the "press the reset button and upload" sequence. No go with that too.

the blinking program uploaded the first time works everytime I plug in the USB port.

Trying to update the driver resulted in the message saying that I've the updated driver.


Fjornir

Are you sure that COM19 is the right port to use?

wongster

#3
Feb 04, 2009, 04:47 am Last Edit: Feb 04, 2009, 05:56 am by wongster Reason: 1
HI Fjornir,

Thanks for replying.  Appreciate it.

That's the port number show on control panel when I followed the instruction to set it up.  Also, I successfully uploaded the 2 sketches following the tutorials (both are blinking LEDs sketches - the first 2 in the tutorial section).

I tried uninstalling both the USB driver and the com port and reinstall them again.  Same problem occurred.

Regards
Wongster

Fjornir

Pull down Tools | Serial Port and try the other ports that're listed there.


Go Up