Go Down

Topic: Problems installing on OpenSuSE 11.2 / 32bit (Read 402 times) previous topic - next topic

LiviuS, YO5QCD

Hello good people,

I've recently installed opensuse11.2 on an Intel P-IV singlecore biig machine, with plenty of ram and stuff. Previously I ran on this machine the 10.3 version of the same distro, on which the Arduino-0017 stuff worked just perfect with any of my three Duemilanove genuine boards...
On the "brand new" and heavily updated system (via updater applet) I've tried to install the Arduino-0018. The first attempt  was made following the steps described in the Playground section of the website.
As usual I've tested the installation with the famous Examples>Digital>Blink. The compile command returned as first error:
"unknown MCU 'atmega328p' specified" and a list of known MCUs, then folowed by lots of errors. No use to post all of them here, just an example:

/yo5qcd/bin/arduino-0018/hardware/arduino/cores/arduino/wiring.h:107: error: expected ')' before 'int'

Obviously something went wrong... so I removed everything (symlinks included) and followed the steps described in this forum, then those on sites Google knows where else... The same happened each time.

Oookayy... so let's downgrade to the good old 0017. But surprise: the result was exactly the same... Moreover,  I have done it in the Windoze-style, logging in and out or even rebooting...

No problem, instead, on Ubuntu Karmic or on WinXPsp3, both on the tiny netbook AOD-250... Unfortunately, the "company's standard" stucks me on openSuSE so I have to find some solution for this (otherwise very powerful) distro.
What I'm forgetting, doing wrong, misusing or misconfiguring ?? Anyone out there could help? Thanks!

wayoda


LiviuS, YO5QCD

Thank you Eberhart, for the link, but for me it is useless. At the very beginning of my post I explained that for me the installation failed when following those instructions.

If someone has encountered the same problem and solved it, please share...

wayoda


Go Up