Go Down

Topic: avrdude version problem (Read 369 times) previous topic - next topic

Mark S

May 30, 2010, 06:22 am Last Edit: May 30, 2010, 06:24 am by msproul Reason: 1
I am running Arduino 0018 on a Mac and it has
       avr-gcc version 4.3.2 and
       avrdude Version 5.4-arduino, compiled on Oct  9 2007 at 11:20:31

I tried to upgrade to version 4.3.3 (Crosspack installation) which has
      avrdude Version 5.8cvs, compiled on Jan 15 2010 at 17:27:01

The compiler works fine and I can do normal things but I cannot burn the bootloader. It erases the chip but I get this error and it does not burn the bootloader.  If I switch back to 4.3.2 it works fine so its not the bootloader file.

I checked the avrdude.conf file and there are no changes for the 1280 chip.

Any ideas?

avrdude: ERROR: address 0x10f010 out of range at line 2 of /Applications/Arduino.app/Contents/Resources/Java/hardware/arduino/bootloaders/atmega/stk500v2_mega1280_boot.hex
avrdude: write to file '/Applications/Arduino.app/Contents/Resources/Java/hardware/arduino/bootloaders/atmega/stk500v2_mega1280_boot.hex' failed

the new avrdude works fine talking to the chip in command line mode. However I have not tried to burn anything that way.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy