Go Down

Topic: Arduino IDE won't start on windows XP (Read 11159 times) previous topic - next topic

Andy_B

Thanks for the help. Being a bit dumb, I didn't realise that the bat file would make the program start (I just thought it was a config) as it takes like 5 mins to launch on my weird set up. Great to have Arduino back though.

tuomo

#16
Mar 18, 2006, 01:01 am Last Edit: Mar 18, 2006, 01:10 am by tuomo Reason: 1
I just got this same problem on my XP (sp2). I think I installed processing and some games after previous Arduino use and now it doesn't start. The proposed run.bat fix did not help either. Any ideas? New machine, no exotic softwares yet, apart from Arduino & Processing :-)

(one minute after)
Ehh, I did not realize that I should _launch_ it now from the run.bat. Works now. I think I stick on to my mac. I don't understand running bats. In Finland they fly :P

jw

Hey, something else...  i had the same startup trouble at first, fixing the.bat made the .exe start the arduino IDE, too. but very slow, as described before. then i realised, that i had like 10 COM ports from dirty bluetooh uninstallations on my machine, disabled them all and now the IDE is up in 2 seconds... but only when my bluetooth dongle is plugged in. for all who the .bat fix doesnt help, check your COM ports.

jens

cdreid

Arduino wont run for me either now. It ran at first and to my knowledge i changed nothing. I've reinstalled several times/several versions. I think it might have updated java though im not sure (windows is NOT java friendly. ).

I've tried editing the run.bat file. Not only to reset the path but to manually change the settings etc. AT one time i got a strange "didnt expect goto" error so i removed the error checking. Nothing works.

I'm getting out of bounds errors which sounds like either coding or memory errors. Btw i increased the settings to 256m. The only change was a second more before it crashed (before loading the gui).
Please note this is most likely a (as usual) M$ screwup as they seem to hire monkeys as lead programmers and use us as unknowing alpa testers.

Please help. Love the arduino concept (there should be a mega-arduino with zif sockets and multi mc support!)  but the software side is lacking.



On a side note i'm very curious as  to whether it would be possible to use the arduino as a straight usb programmer simply outputting the file to the data pins using them as mosi/miso/reset etc.



mellis

Can you try running Arduino 0005 with the original run.bat and post the exact error you get (if it's in a dialog box, you might be able to press Ctrl-C to copy the text, even if you can't select it)?  You might also try installing Java (you should only need the runtime, not the SDK) yourself instead of using the one that comes with Arduino; just change the set JAVA_HOME="java\bin" line in run.bat to point to your Java.

cdreid

im typing this by hand so forgive any errors.

Exception in thread "main" java.lang.StringIndexOutOfBoundsException: String index out of range: -1

at java.lang.String.Substring(unknown source)
at java.lang.String.Substring(unknown source)
at processing.app.Preferences.setColor(Preferences.java:698)
at processing.app.Preferences.init(Preferences.java:165)
at processing.app.Editor.<init><Editor.java:151>
at processing.app.Base.<init><Base.java:202>
at processing.app.Base.main<base.java:177>




That is using my main java install.  I just tried the arduino install and it gives identical errors.
(PS wouldnt it be nice if winblowz hack programmers would quit trying to screw up even nonWinblow$ systems like Java?????)

mellis

The error message was very helpful.  It appears you've found a bug in Arduino triggered when the system setting for the default background color of a control is assigned to certain values.  Did you change your theme/display settings recently?  If so, you might try changing them back.  I'll try to get this fixed in the next version of Arduino.

cdreid

Do you have a fix for this? Were you able to reproduce it? Because it makes the arduino board a bit useless. I havent changed any of the display settings and have repeatedly downloaded different versions of the software. I just tried messing with my laptop display settings to no avail.

Im going to try to mess with preferences.txt in a copy of arduino-005 to see if i can get something going now.

Makes me wish i were at home so i could just build a usb dev board til this hideous bug is fixed :(
Btw thanks a lot for your quick and concerned responses.

cdreid

Fixed the problem. First i downloaded the arduino-006 update.

Afterwards i reinstalled java (again). Went into the c/program files java directory. Copied the current java version subdirectory (java/blabla1.09 or whatever) to the arduino/java directory. overwrote all the files in arduino/java with the contents of arduino/java/java1.09(or whatever) subdirectory.

Rebooted etc etc 23423432 times til i got xp and the arduino to agree on a serial port. reinserted arduino. reran arduino and it worked. Finally. Thanks be to god.

david.vondle

For what it's worth, I don't have Cygwin, and am running a relatively new install of XP.  I am having the same problem.  The run.bat works though.

-Dave

jabstarr

hi,

im having trouble running the arduino IDE (both 007 and 008) in XP SP2 as well. it starts up, but acts all weird.

its been a while since i've used arduino on my laptop, but arduino 007 worked just fine 6 months ago. i have updated java in the mean time to the following version:

Java Plug-in 1.6.0_01
Using JRE version 1.6.0_01 Java HotSpot(TM) Client VM

the IDE starts up, but slowly, and reacts strangely too. for instance: the first 3 menus work just fine, tools and help are slooow.

i've tried running run.bat on both 007 and 008 and its the same behaviour.

also, i've deleted any extra COM ports from my setup... still no luck.

only files named anything with cygwin on my computer is in the arduino folders.

processing runs just fine.

can anyone help, plz?

/j

jabstarr

#26
Jul 26, 2007, 01:11 am Last Edit: Jul 26, 2007, 01:12 am by jabstarr Reason: 1
i just managed to download a sketch to my USB arduino - - i had to wait approx 15s before pressing reset on the board - - so it seems that everything is working - - but REALLY slowly  :-/

mellis

You might have better luck with an older version of Java.  The Arduino environment is heavily based on Processing, and Processing still uses 1.4.2_12.  Apparently Sun's idea of backwards compatibility doesn't include performance.

jabstarr

oh, OK...
is there a way of making arduino use an older version of java without uninstalling the newest version from my computer?
i mean - processing does it, right?

jabstarr

i just tried moving the jre1.6.0 and jre1.6.0_01 folders from my java directory, only leaving jre1.5.0_10 - - this didn't help - - i'm not much of a windows wiz . . . should i uninstall some other way?

Go Up