Go Down

Topic: Arduino IDE won't start on windows XP (Read 11157 times) previous topic - next topic


Try running Arduino with the run.bat script.  


Jul 27, 2007, 02:12 pm Last Edit: Jul 27, 2007, 02:13 pm by jabstarr Reason: 1
i did already - - same result, also with java 1.6 disabled (that is with the 1.6 folders moved out of program files>java)

starting up with run.bat and java1.5 i get the msg:
native lib version = RXTX-2.1-7
java lib version = RXTX-2.1-7

i don't know if this can help...

(oh: missing my old mac these days)


hello again,
i uninstalled all java runtime environments with control panel>add/remove programs, downloaded java version, installed that, reinstalled arduino IDE. still the same slow response. running run.bat yields the same behavior. this is unbearable.
has anyone been able to fix this??
i can't think of anything anymore... please help!  :'(


I don't think the problem is the Java version, as run.bat should use the Java that comes with Arduino regardless of what you have installed.  It sounds like spawning external programs is what's slow, as that's used for compilation, upload, and also to rebuild the "Serial Port" menu when you open the Tools menu.  One Google result I found suggested making sure you have plenty of free memory.  I'd take a look at what else you have running.  There's also another fix (explicitly adding '.exe' to the command) that I can try putting into the next release.


Jan 27, 2008, 09:24 pm Last Edit: Jan 27, 2008, 09:25 pm by joker Reason: 1
:-/ same pb happened to me.
Every thing worked perfect while using arduino-007 and then arduino-010. Then I made a real big mistake while testing a prototype interface (I fed the +5V with some +12V high amps  :P ). So as to say, I prepared a roasted ATMEGA168  :-[ . I checked it anyway: power supply is OK, FTDI interface is OK, but communication problem with the processor.
Here is the important information: I decided to upload a fresh bootloader, so that I added to install WinAVR on my PC. Since that time, I cannot launch arduino.exe, unless I use the run.bat script. (And my processor is definetly dead)
Very confusing indeed  :-?


Happy again!  ;)
I removed WinAVR, used CCleaner, and everything is order again  :) except the chip  :P


Feb 14, 2008, 12:10 am Last Edit: Feb 14, 2008, 12:16 am by tkbyd Reason: 1
Do I infer from Mellis's post that "Run.bat" is an alternative way to get into the Arduino development environment?

FWIW, I'm using Arduino.exe (010) on an XP machine, and it seems happy enough. No Processing. No cygwin. Java RTE 1.6.0_03

(Wow! Busy thread! This used to say "previous post", 'cause when I went to write it, none of the several intervening posts were up yet!)


hey everybody,
i want to compile the USBKeyboard, for this i need the IDE v0016. v0018 and v0017 working well on my XP. if i try to open v0016 nothing happends.. so i tried all tricks you duiscussing here.. nothing works, not the bat... NOTHING..
it doesnt work on 2 different XP maschines and not on a Windows7
on a Server 2003 it works.
i cant understand anymore. i tried everything of your tips here... the bat gives me following message:
Code: [Select]

Native lib Version = RXTX-2.1-7
Java lib Version = RXTX-2.1-7
Exception in thread "main"
java.lang.NumberFormatException: null
 at java.lang.Integer.parseInt<Unknown Source>
 at java.lang.Integer.parseInt<Unknown Source>
 at processing.app.Preferences.getInteger<Preferences.java:750>
 at processing.app.Editor.restorePreferences<Editor.java:420>
 at processing.app.Base.<init><Base.java:143>
 at processing.app.Base.main<Base.java:104>

i need really fast help. pls pls pls help me... im close to cry  :'(


Hi, quick solution:
remove the preferences.txt file.

Start arduino-0018
remember the location of the 'preferences.txt' file given on that dialog
Close the IDE
remove the 'preferences.txt' file
Start arduino-0016 (will prompt you for the sketchbook loaction again)

A much better solution would be trying to find out why you can't use 0018 for your project.



danke eberhard,
warum das nicht funktioniert, weiß ich nicht, auf rückfrage mit dem programmierer sagte er mir das..
auf jedenfall klappt jetzt alles.
you saved my day


Try right clicking on the arduino  ide  exe and running as administrator. I run vista 32 bit and this solved it for me.  Not sure exactly the problem but worth a shot.

Go Up