Go Down

Topic: java.lang.NullPointerException Problem (Read 7928 times) previous topic - next topic

mengineer

Jun 16, 2010, 12:32 am Last Edit: Jun 16, 2010, 03:41 am by irishMEngineer Reason: 1
I've been using the Compiler for a long time with no problems now all of the sudden I'm getting the following errors :
Code: [Select]
java.lang.NullPointerException
     at processing.app.debug.Compiler.compile(Compiler.java:75)
     at processing.app.Sketch.build(Sketch.java:1412)
     at processing.app.Sketch.compile(Sketch.java:1203)
     at processing.app.Editor$44.run(Editor.java:1807)
     at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
     at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
     at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
     at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
     at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
     at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
     at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
     at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
I'm searching for the latest java update now to see what happens. I tried uninstalling the compiler and reinstalling  just to get the same problem. Looking to see if anyone else has had this problem and found a fix. If it helps I'm running Windows 7 64-Bit. I usually don't have problems figuring this stuff out but I'm puzzled right now.I have tried to just verify every simple sketch included and some I wrote and this occurs. If I try to upload it's the same as well. The java update did nothing.

mengineer

Well I got it working again, after another update and cleaning out some temp folders.

Scott Baker

I get those errors maybe 1 out of every 10 times. Usually I just hit compile again and it's good to go. Was the problem occurring every time?

andrea0206

I'm still having the same problem what should we do to solve it?

PaulS

Does the problem persist no matter what sketch is being edited?

Vini

I'm having the same problem!
can anyone help us?

PaulS

I'll ask the same question I asked earlier. Does this exception occur when compiling any sketch, or only a specific sketch?

If it is a specific sketch, post it.

Vini

@PaulS

This occur when compiling any sketch (like the blink one)

Andrew

I got a java.lang.NullPointerException when I reinstalled the Arduino IDE and tried to compile a sketch without selecting a hardware board. Make sure something (e.g. Duemilanove with ATmega328) is selected under the Tools, Board menu first.

Andrew

Vini

BINGO!

Congratulations Andrew, you solved the problem!

THANKS!  :D


Go Up