Go Down

Topic: arduino0021 extraction & avr-g++ problems (Read 1 time) previous topic - next topic

mrl3086

Brief Overview of Problems:

After several attempts at extracting the contents of the arduino0021 zipped folder that I downloaded off of this site, I get the same error.

Also, I just plugged my brand new Arduino board into my computer, and lo and behold, I go to run the "Blink" program, and problems already!

Not sure if these things are related, but who wants pesky errors!! Figured I'd mention them both.


Important Info:

OS - Windows 7 32bit
Board - Arduino Duemilanove (Atmega328)
Anything else - Let me know!


Detailed Explanation of Errors:

The error I received on extracting arduino0021 is:
bad CRC c20374c8 (should be 17a8c13d)

From my brief exposure to microcomputing, this is some sort of address in hex? And it was expecting to find something, but the something wasn't there? I continued with the extraction, skipping this problem, and I encountered no more errors.

After starting up arduino.exe, I plugged in the board and waited for Windows to install everything, and that returned no errors. Then I checked to make sure that everything was set in the arduino environment - correct board and serial port were selected.

When uploading the Blink program to the board, I received the error message:
avr-g++: CreateProcess: No such file or directory

I also tried the Fade program, and I got the exact same error message. I also plugged an LED into Pin 13 to make sure that the bootloader was present and accounted for, and it is! It is blinking in a certain code though...5 blinks I think before it stays on and then off for about a second each? Thought it was worth mentioning, I'm very new to this so sorry if this is normal behavior!

I would appreciate greatly any help with this, as it is quite the buzz kill when things don't work right out of the box! Sorry also for the lengthy post!

Coding Badly

Quote
The error I received on extracting arduino0021 is:
bad CRC c20374c8 (should be 17a8c13d)

The download is corrupt.  Before continuing, redownload and reinstall.

mrl3086

Wow that fixed all my problems. Thank you so much!!  ;D

Go Up