Pages: [1]   Go Down
Author Topic: Uno works on Vista PC, but stopped working on XP  (Read 1156 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I recently got an arduino Uno and have had great success and fun using it with both my Windows XP 64-bit SP3 laptop and my WinVista 64-bit machine.  However, I haven't been able to upload sketches from my laptop to my arduino in the last couple of days.  The error I get is :

Binary sketch size: 2784 bytes (of a 32256 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

The arduino still takes uploads from my desktop just fine, but I want to be able to do some work with it while I'm at school too.  Here is a list of things I've tried/double-checked

-restart PC
-uninstalled bluesoleil
-checked com and board in arduino 0021
-unplugged everything but USB cable from arduino
-pressed reset button on arduino
-uploaded different programs successfully with other computers
-shutdown many other programs

I was doing some work with a bluetooth dongle, but i'm pretty sure that i had been working with the bluetooth and the arduino at the same time and they both had been working great.  Any other suggestions?  I'm new to arduino and physical computing in general so feel free to throw out things that might be obvious to most.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 210
Posts: 13030
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


Try a different USB cable.

It's a single Uno you're shuttling between the two computers?
« Last Edit: November 19, 2010, 02:11:59 pm by bcook » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yea, it's a single Uno that syncs up great with one computer running vista and stopped working with my winxp computer.  I think I may have another cable that I can try, but I guess I'm not quite sure what that will do though since the cable works great when connected to vista.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 210
Posts: 13030
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I think I may have another cable that I can try, but I guess I'm not quite sure what that will do though since the cable works great when connected to vista.
In that case, I misunderstood your setup.  I assumed you had one USB cable for each computer and you shuttled just the Uno between the two computers.  Trying another cable will not help.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

any suggestions on other things I should try?  I'm tempted to just format my winxp machine and start from scratch.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 210
Posts: 13030
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


Have you tried a different USB port?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yup, I've tried every different USB port.  I even uninstalled and re-installed drivers in between and restarted the computer.  Windows will recognize that it's plugged in, the drivers get installed, and it is there under ports in the device manager as an arduino uno, but for some reason I still get the same problem every time I try uploading.  The arduino doesn't react at all to the upload attempt.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 210
Posts: 13030
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


What happens if you press the reset button on the Arduino and then very shortly afterward click the upload button in the IDE?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

If i press reset and then immediately click upload in the IDE, the led marked "L" flashes three times in quick succession and the IDE gives me the same error message as usual.  Still works on my vista machine though.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 210
Posts: 13030
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


The only thing left is to make certain you've selected the correct serial port and board.
Logged

Pages: [1]   Go Up
Jump to: