Go Down

Topic: Stuck in Uploading to I/O Board with Mega 2560 (Read 9 times) previous topic - next topic

fillibar

#10
Jan 09, 2011, 03:47 pm Last Edit: Jan 09, 2011, 04:19 pm by fillibar Reason: 1
I created this thread in the Bugs & Suggestions category:
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1294536128/0#0

I will edit it to add the point about you trying with Ubuntu and using 0021. I do not know if anything would result from it but it does not hurt to include all the details.

Does anyone reading this have an Uno they could try this out on? I am curious about whether it is a Mega 2560 problem or both of the new Arduinos being affected.

mmcp42

just tried it on a UNO
works fine
uploaded ok and serial monitor is showing

Alaarm trigger integer xxx
Incrementing integer xxx
Alarm has gone off!!!
there are only 10 types of people
them that understands binary
and them that doesn't

fillibar

Excellent, thanks for the input about the Uno. So as much as can reasonably be tested this is a Mega 2560 specific problem.

bubulindo

Did anyone try with longer strings??? replacing the exclamation mark with another character and trying again?

It might be something else than an exclamation mark...
Eu não sou o teu criado. Se respondo no fórum é para ajudar todos mediante a minha disponibilidade e disposição. Responder por mensagem pessoal iria contra o propósito do fórum e por isso evito-o.
Se realmente pretendes que eu te ajude por mensagem pessoal, então podemos chegar a um acordo e contrato onde me pagas pela ajuda que eu fornecer e poderás então definir os termos de confidencialidade do meu serviço. De forma contrária toda e qualquer ajuda que eu der tem de ser visível a todos os participantes do fórum (será boa ideia, veres o significado da palavra fórum).
Nota também que eu não me responsabilizo por parvoíces escritas neste espaço pelo que se vais seguir algo dito por mim, entende que o farás por tua conta e risco.

Dito isto, mensagens pessoais só se forem pessoais, ou seja, se já interagimos de alguma forma no passado ou se me pretendes convidar para uma churrascada com cerveja (paga por ti, obviamente).

fillibar

#14
Jan 12, 2011, 02:09 am Last Edit: Jan 12, 2011, 02:38 am by fillibar Reason: 1
I tried with a variety of strings including many that are longer (since I have many debug strings built in as I learn) but I have not tried other specialty characters. Something to check... I will come back with some results.

Edit - Tried with sets of the following characters and all succeeded:
` ~ @ # $ % ^ & * ( ) - _ = + [ { ] } | ; : ' , < . > / ?

Obviously using the following will not work (and yes I tried to prove it):
\ "
And the infamous !

Go Up