Go Down

Topic: LED Upload Confirmation Blink (Read 1 time) previous topic - next topic

rjb707

      I'm having problems loading a 15,500 byte sketch to my Arduino Mini Pro 328 .
Everything is set up correctly because it will accept and run various versions
of the blink sketch , but no matter what I load I never get the final
confirmation blink from the green LED that comes at the end of the upload . The
arduino IDE tells me the sketches are uploaded with no errors or complaints ,
but no final blink and the large programs I want to run don't do what they should.  I can't
tell what the program is doing but the Mini Pro just sits there and blinks
about once every 2 seconds.  

I'm trying to upload a sketch for connecting a
Wii Motion Plus for quadcopter stabilization and I have 2 other Arduino's -same
model which will accept and properly run the sketch.  Is it possible the flash
memory has somehow been corrupted ?  Is there a program to set all the memory
space to 0 or somehow set all the memory to 0  past the point where the sketch
is uploaded ?  I don't know much about the technical aspects of uploading a
sketch so any ideas are welcome.  Also I would be interested in whether you think
this is a hardware issue  - I've done a continuity check between all pinouts and
the 328 chip and they seem to be OK .  I've also uploaded the example sketch
to clear EEPROM memory and it seems to work (no final LED upload blink ) but it
gives me a solid green LED when the program runs.  
Any suggestions would be appreciated.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy