Pages: [1]   Go Down
Author Topic: Problem with new bootloader on old arduino duemi  (Read 1751 times)
0 Members and 1 Guest are viewing this topic.
Greece
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino Greece
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Problem with new bootloader on old arduino duemilanove. Only work with USB Power. with External Power the Arduino don't startup. something strange.. downgrade and works again.... smiley

 smiley-razz
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 601
Posts: 48543
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Which new bootloader?
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 197
Posts: 12739
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


I think he's referring to the Uno bootloader: Optiboot.
« Last Edit: October 04, 2010, 03:09:00 pm by bcook » Logged

Left Coast, CA (USA)
Offline Offline
Brattain Member
*****
Karma: 361
Posts: 17259
Measurement changes behavior
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
something strange

 That is very strange indeed as the AVR chip and bootloader code have absolutely no control over the auto-voltage switching hardware circuitry on the board. So the power led fails to light when you try to use just external power but does work when using USB power, but does all work normally when you re-burned to original bootloader? Again bizarre as auto voltage select should work even if you don't have a AVR chip plugged into the board!

Lefty
« Last Edit: October 04, 2010, 03:46:35 pm by retrolefty » Logged

0
Offline Offline
Faraday Member
**
Karma: 16
Posts: 2857
ruggedcircuits.com
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Bizarre indeed. The only thing I can think of is some interaction between the bootloader and Tx/Rx lines. Without USB connected maybe those lines are floating, and the bootloader doesn't enable pullups???

Pure speculation....and I can't believe it would take this long for this issue to be discovered.

Or maybe the regulator is failing and the voltage isn't quite 5V, so switching to 115200bps causes failure while 57600bps doesn't?

--
The Quick Shield: breakout all 28 pins to quick-connect terminals
Logged

Lancashire, UK
Offline Offline
Edison Member
*
Karma: 9
Posts: 1991
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hmmm, I mentioned this in another thread.  I put the Uno bootloader on a duemilanove and it caused problems with a long running sketch I use for home monitoring/control.  The LCD panel displayed garbage and the heartbeat LED started flashing out of sync.  I just pulled the board and put the old bootloader back.  Quite a complex sketch and I'm not really in the mood to pick the bones out of getting it to work with the new bootloader.

 Its powered by USB on my setup, it ran OK 'dry' but took aversion when I plugged in its shield carrying the connections to the sensors and LCD panel. Again, it works perfectly when I put the old bootloader back.

I tried optiboot a month or two back back and it had issues then, I'm surprised they went for it on a production system to be honest.
Logged


Left Coast, CA (USA)
Offline Offline
Brattain Member
*****
Karma: 361
Posts: 17259
Measurement changes behavior
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I tried optiboot a month or two back back and it had issues then, I'm surprised they went for it on a production system to be honest.

 Not owning a Uno, I think I will just stay clear of version 20/21 and the new bootloader until all the issues and bugs get addressed.

Lefty

Logged

Greece
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino Greece
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm talking about Duemilanove. I put the bootloader (for UNO) that I found in the IDE 21 but I tried and optiv3. When powered from the external power LED PWR lights but the AVR will not boot. Trends in 3v and 5v Pin is OK. With USB works, however, and there is a strange behavior. Sometimes when uploading the Sketch and run when I remove the USB and put it back, it seems the AVR have no Sketch .. strange. (Not all the time .. i thing 1 or 2 times did this).


So I decided to downgrade to the old bootloader that everything is working well.
« Last Edit: October 04, 2010, 07:23:08 pm by DolceVii » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 21
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am having similar problems with Optiboot and Duemillanove. After burning a new bootloader (optiboot) Duemillanove does not boot from external power sometimes. With USB power it boots. Still, someteimes Duemilla nove is able to boot from external power only. when it doesn't boot, the led starts to blink like it is in some kind of eternal loop. What helps, is when I wait few minutes after trying again to power it from external power.
But when Duemilla nove is up and working, restarts from software or watchdog won't hang it. Very strange phenomena indeed.
But i need optiboot for watchdog! What is an alternative? To use adaboot?
Logged

Lancashire, UK
Offline Offline
Edison Member
*
Karma: 9
Posts: 1991
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1295516707/0#2

Try this, its the first time optiboot has been usable for me, even to the extent of putting a Duemilanove bootloader on my Uno to get around the problems it caused.
Logged


Pages: [1]   Go Up
Jump to: