Pages: [1]   Go Down
Author Topic: Trouble starting IDE  (Read 2519 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have just purchased the arduino Uno, and naturally I would like to be able to use it. However, I use linux (Ubuntu 10.10) and the default version of the IDE is 0018. This means I need to install a newer version to be able to use my shiny new toy. I have followed the instructions to build the latest version (0022), which seemed to be successful. When using ant run, the "Select a folder for sketches" dialogue comes up and I can choose where I wish for them to be saved, but then nothing happens after I make my choice. From the terminal after that step:
Code:
    [exec] java.lang.UnsatisfiedLinkError: /home/scott/Arduino/build/linux/work/lib/librxtxSerial.so: /home/scott/Arduino/build/linux/work/lib/librxtxSerial.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch) thrown while loading gnu.io.RXTXCommDriver
     [exec] Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/scott/Arduino/build/linux/work/lib/librxtxSerial.so: /home/scott/Arduino/build/linux/work/lib/librxtxSerial.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
     [exec]       at java.lang.ClassLoader$NativeLibrary.load(Native Method)
     [exec]       at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1750)
     [exec]       at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1675)
     [exec]       at java.lang.Runtime.loadLibrary0(Runtime.java:840)
     [exec]       at java.lang.System.loadLibrary(System.java:1047)
     [exec]       at gnu.io.CommPortIdentifier.<clinit>(CommPortIdentifier.java:83)
     [exec]       at processing.app.Editor.populateSerialMenu(Editor.java:957)
     [exec]       at processing.app.Editor.buildToolsMenu(Editor.java:694)
     [exec]       at processing.app.Editor.buildMenuBar(Editor.java:479)
     [exec]       at processing.app.Editor.<init>(Editor.java:201)
     [exec]       at processing.app.Base.handleOpen(Base.java:699)
     [exec]       at processing.app.Base.handleOpen(Base.java:664)
     [exec]       at processing.app.Base.handleNew(Base.java:561)
     [exec]       at processing.app.Base.<init>(Base.java:301)
     [exec]       at processing.app.Base.main(Base.java:190)


I have tried to search through the Googles and interwebs, but none of the suggestions I have found have gotten me any farther. I would greatly appreciate any help anyone could give to actually get the IDE up and running. I would much prefer to spend my free time playing with the arduino.
Logged

0
Offline Offline
Newbie
*
Karma: 2
Posts: 34
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have experience IDE hanging when I open sketches.
Using Ubuntu 10.4, my best solution is to unplug the Uno and press reset several times.
The ACM0 comes and goes randomly...mostly goes.

Posting to see if somebody has better solutions.  :-/
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have found a solution, thanks to mrtaylor!
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1295562202/3#3
I just followed his instructions, and arduino 22 loads up properly, not to actually try something out with it...
Logged

Pages: [1]   Go Up
Jump to: