Go Down

Topic: COM4 Serial Port not showing up (Read 39724 times) previous topic - next topic


Under Device Manager, my Arduino Mega 2560 is connected via USB to COM4. However, when I go to upload a program to it, under Tools -> Serial Ports, only COM3 shows up. My drivers are up to date. Also, COM3 seems to be in use, according to Device Manager. COM3 is the only one that shows up, regardless of whether or not the Arduino is actually connected. Any help would be appreciated.


What operating system are you using? I know that Windows 64 bit has trouble with connecting sometimes.


Windows 7 x64. Is there any way to fix these problems?


Download this: http://www.ftdichip.com/Drivers/VCP.htm (scroll down and get the 64 bit version) and go to Device Manager.  Select your Arduino and click update driver software in the top bar, and select Browse my computer for driver software.  Then select the file (once you extracted it) and make sure include subfolders is checked.  If all goes planned it should be up and running.   XD


Download this

The 2560 does not have an FTDI chip on board, so installing the FTDI drivers will be a waste of time.

It does appear, though, that OP has a driver issue.

Nice that the new forum strips out names in reply mode.

OP, when you were prompted to install drivers for the 2560, what, exactly, did you do?
The art of getting good answers lies in asking good questions.


Also, what kind of device does the Mega show up as in the Device Manager?  Does it appear as being fully functional.  You could try editing your preferences.txt file (you can find its location in the preferences dialog) and manually set the port to COM4.  (Be sure to edit the file when the Arduino software is not running.)  Then restart Arduino and try to upload.


I have been having the same problem intermittently with my UNO board and my Vista laptop (running Arduino-0022 IDE & drivers).  It takes shutting the IDE down and hard-resetting the board (unplug from USB and plug back in) to restore functionality (for a while, at least).

On my Win7 x64 desktop, I haven't had a single problem with the same software and drivers installed (I'm blaming it on a bad download - I've had bad drivers corrupt downloads before).

Try downloading the IDE again and see if that gets you anywhere.


Alright, so it works now. I had installed the drivers a few weeks ago and it worked fine, and when I went to update the drivers again, Windows said the drivers were up to date. Today I updated them manually, and it worked. Guess the drivers might have been corrupted. Oh well, as long as it work. Thanks!


Why are you still using -0022? That's what, 3 years old now?
Move  up to 1.05 at least.
Scroll down here
and see all the things that have been fixed & improved.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

Go Up