Go Down

Topic: Uno problems with Win7 64bit (Read 576 times) previous topic - next topic

ardshark

First what works:
The arduino Uno R3 works fine on a mac running 10.68 so to my mind that means the boot loader is fine, and the arduino is fine.
Moving to the PC:
Device shows up in the DMports (com3). For fun I've uninstalled the device, then pulled the cable, put the cable back in, updated the driver and pointed it at the R3.inf. There was of a course a problem with the driver installing due to lack of signage but the device does show up and is assigned a port. (i have also tried forcing other ports in the advanced tab of DM properties)
Port is set to 9600
In the IDE (22,23,1.03,1.05 -yep tried them all) in tools the board type is Uno and the port is 3 (although no name shows up beside that port)
Uploading a sketch fails and yields:

avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

No other software is running and the IDE and machine have been restarted hundreds of time through this process.
Now I've done this a thousand times before and suddenly my Unos, my diecimila's and my sanguinos won't load sketches on the PC.
I can load all my sketches on the mac but in the end they will be running off a PC, and I've tried talking to a (mac loaded) board on a PC through the serial port and it's like it's not even there. (and this does work on the mac)
This has plagued me for two days so there is very little I haven't tried.

Thoughts?


dshimo

I had problems on arduino uno to work with xp  :0.I look for help for about 2 days I got it to work   XD,it was do with the CH340 chip on the arduino uno ,I download this http://www.winchiphead.com/download/CH341/CH341SER.ZIP  the website I got it was http://club.dx.com/forums/forums.dx/threadid.635690

ardshark

Success!
In my case it was a Renesas usb driver for other devices (like mice and keyboards). I don't remember installing this so i may have installed itself when a certain mouse or keyboard was used.
Removing this has killed the use of all my chosen USB peripherals and I'm now searching for compatible hardware and drivers that will still allow the arduino to function as well.
I though this was the whole point of multiple ports -  so that you could run different hardware.
What I don't know is if this is an issue with the arduino implementation of the port calls or an overbearing Renesas driver hammering away on all ports, drowning out meek whimpers from the arduinos.

archy587

Hey Im having this exact problem but the drivers dont seem to install correctly for me.

My UNO board shows up as CH340 com14, but it thinks its a mouse. When it thinks it is working correctly i totally lose control of my cursor lol.

do those drivers still work for you, or have they been updated? how did you install them? I went through the whole update driver thing, then have disk and point it at the CH341SER folder, but it installs as a mouse.

any ideas?? thanks!

ardshark

It might be that the port number is just to high -  we've had problem with anything over port 9.  You can force that down by getting the properties of the port in the device manager and hitting advanced and changing to something lower you know is open. We found that in some cases each time you connect the board to the computer the port would increment higher.

What rev of Uno is you board? You might have to go back to previous version of the arduino driver to get that work.

ardshark

And just to double check because those icons looked a little different to me -  is that vista or win 7?

archy587

ok i messaged the seller and they sent me a link to their driver, which looks identical to the others for the CH340T arduinos.

I installed that driver and took your suggestion to set the com port number to 2.

the combination of the two seems to work. I can upload sketches and my cursor doesn't glitch out when I plug in the board, but under devices and printers the icon still shows up as a mouse, (USB-Serial CH340 (COM 2)).

all in all i guess its working correctly. Most likely it was the high com port number causing the problem. thanks for that advice.

and my OS is Win7 Ultimate Sp1

Go Up