First suggestion: The this-> stuff looks amateurish. 99.99% of the time, it is not needed. Get rid of it, except in that 0.01% of the time that it is needed.
Second suggestion: Posting code snippets that omit key information, like how _longNextStepTime and _intStepInterval are defined is not the best way to get help. Including long and int in the names is no assurance that the variables are actually defined that way.
Third suggestion: Addition involving variables that can roll over, such as the return value from micros(), is a bad idea. Subtraction is guaranteed to work. Addition is not. Restructure the test to involve subtraction, not addition.
Fourth suggestion: This code:
if( this->_intStepsRemaining < 1 ) return false;
else return true;
would be much clearer as
return (intStepsRemaining > 0);
The value in the parentheses will evaluate to true (if steps remaining is positive) or false (if no steps remaining).
_intStepInterval, amusingly enough, is at roughly -24000
This tells me that _intStepInterval is not properly defined as unsigned long.