Go Down

Topic: tlc5940nt auf 12v (Read 4 times) previous topic - next topic

uwefed

Quote
Anscheinend hatte der letzte TLC der reihe einen Hau und hat bei meiner externen 5V-Schaltung einen Kurzschluss verursacht, der die anderen beiden angeröstet hat.

Wenn der letzte eine Macke hatte und einen Kurzschluß verursacht hat dann ist es sehr unwahrscheinlich daß die anderen beiden dabei kaputtgehen.

Quote
Hab jetzt allerdings ein neues Phänomen. Wenn ich den TLC über extern 5V versorge und die 5V vom Arduino entferne, "stottern" die TLCs und lassen sich nicht korrekt ansteuern.

Heißt das, daß der Arduino dann ohne Spannungsversorgung ist oder versorgst Du den auch über das externe Netzteil?

Viele Grüße Uwe


Realizer

#16
Jan 28, 2011, 11:29 pm Last Edit: Jan 28, 2011, 11:37 pm by Realizer Reason: 1
Quote
Vielleicht sollte ich einen Elko gegen Masse schalten um die Spannung zu glätten?


Probiers aus. Ich löte, wenns Not am Mann ist aus dem Keller, aus alten Videorecordern oder Radioweckern Elko's raus, bevor sie in den Elektronikschrott wandern. Such dir die dicksten Elkos raus. Zumindest wäre das einen Versuch wert. Entsorgen kannst du sie immer noch wenn der Versuch fehlschlägt.

Nebenbei: Die Anmerkung von Webmeister mit dem strombegrenzenden Labornetzteil ist Gold wert ! Als echter Bastler ein "must have" in jedem Fall.
Ich habe mir daraufhin auch einige Angebote im Internet angeschaut (Weil ich mir ein neues zulegen will) und habe dort einiges brauchbares gefunden. Labornetzteil mit Analoginstrument und Spannung zwischen 0-15 Volt und regelbarer Strombegrenzung für ca 30-40 €. Wichtig ist die regelbare Strombegrenzung. Stellste 300 mA ein, dann regelt das Teiil auch ab 300 mA ab ! Auch als Konstantstromquelle wunderbar zu gebrauchen.
Eine Kuh macht muuhh.
Viele Kuehe machen Muehe

Marcus W


Heißt das, daß der Arduino dann ohne Spannungsversorgung ist oder versorgst Du den auch über das externe Netzteil?

Der Arduino wird nur über USB mit Strom versorgt.

Labornetzteil steht schon auf meinem Wunschzettel - bin morgen im Elektroniklädle meines vertrauens, mal sehen was sich da auftut ;)
Elkos hab ich eh immer daheim - bei oben genanntem Laden kauf ich mir immer so Krabbeltüten vollen Elektronikkleinteile aus alten Geräten; Elkos, Transistoren, Mosfets Widerstände etc - kann nicht genug davon haben ;)

Webmeister

Quote
Die Anmerkung von Webmeister mit dem strombegrenzenden Labornetzteil ist Gold wert ! Als echter Bastler ein "must have" in jedem Fall.

Definitiv, ein Labornetzgerät gehört zur Grundausstattung eines Elektronik-Labors.

Beim Kauf sollte man also, wie Realizer erwähnt, achten, dass das Netzgerät eine regelbare Strombegrenzung hat.
Mittlerweile sind diese Geräte wirklich nicht mehr teuer.

Ich habe meines (0-2.5A, 0-30V) vor Jahren bei Conrad gekauft und es funktioniert immer noch einwandfrei (und hat schon etliche Schaltungen durch die Strombegrenzung vor dem Untergang gerettet  ;) )

uwefed

Hallo Alle.

Im Bezug auf Strombegrenzung muß ich aber einen Warnung aussprechen.
Eine Aktive Strombegrenzung kann bei bestimmten Schaltungen aber auch Fehler hervorrufen oder unerwartetes und unerklärbares Verhalten hervorrufen.

Ich erinnere mich an ein Problem meines Ardbeitskollegen der eine mit Cmos aufgebaute PWM Steuerung einer 150W Halogenlampe reparierte. Die Steuerung hatte nur Tasten zum ein und ausschalten. Die Schaltung war permanent mit Spannung versorgt.
Mein Kollege hatte die Schaltung und Lampe an ein Labornetzgerät gehängt, weil der Trafo fest eingebaut war. Nominell brachte das Netzteil genug Strom für die Glühbirne.

Der wirkliche Fehler war schnell gefunden; ein IC war kaputt und wurde heiß. Gefunden einfach durch Finger drauflegen.

Das Problem blieb, daß wenn man das erste mal nach dem Einschalten des Labornetzteils die Lampe einschalten wollte es nicht funktionierte. Durch manuelles High-Schalten eines Bauteils funktionierte dann alles normal; man konnte ein und ausschalten und regeln.

Nach 1 Woche kam meinem Kollegen die Idee den orginalen Trafo hinzuhängen und siehe da, alles funktionierte richtig.

Das Problem wurde hervorgerufen weil die Glühbirne im Einschaltmoment einen großen Strom zieht und dadurch die Schaltung resettierte. Einmal eingeschaltet schien dann das kein Problem mehr zu sein.

Zusammenfassung:
Verbraucher die einen großen Anlauf oder Einschaltstrom ziehen, können zu Spannungseinbrüchen führen und so die Schaltung stören. Auch Verbrauche, die mehr Strom brauchen als die aktive Strombegrenzung des Netzteils hergibt führen zu einer Erniedrigung der Spannung und darum zu möglichen Fehlfunktionen.

Grüße Uwe






Go Up