Pages: [1]   Go Down
Author Topic: Atmega8-16PU doesn't start on breadboard PSU  (Read 740 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 40
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello. I just build a working project on an Arduino, built it on breadboard and I'm tyring to power the project for the first time using AC.

I have prebuilt 5V/1A switching power supply:
http://dx.com/p/switching-power-supply-board-module-green-5v-1a-151582

There's a problem that the Atmega8 doesn't start with this power supply.

I tried the same breadboard circuit using Arduino 5V output, and [AC-DC 9V/1A adapter] > [L7805 regulator] solution, and both worked.

Why is not that 5V power supply able to boot the Atmega chip? It should have well enough power avalable(my project only draws about 20-50mA, depending how many LEDs are lit).
Powering on(about 10 seconds) draws about 30-31mA with all power supplies.

What can I do to correct the input so that Atmega would boot? Do I need to regulate or filter input somehow, although the power supply is included with filter caps and all that? Output voltage is good 4.98V.

I hope there's some way to get this 5V PSU to work, instead of getting 5V regulated 9V supply and waste power.

Update: I was able to get the same circuit working with that 5V PSU and Attiny2313.
I'd still like to know why is Atmega8 so nitpicky about the input, and how can I avoid the issue using that chip.
« Last Edit: September 17, 2013, 04:38:57 pm by Tuppe » Logged

Offline Offline
Edison Member
*
Karma: 36
Posts: 1219
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I should work.
The ATmega8 will run with a voltage between 4.5V and 5.5V.
Does the ATmega8 have a 100nF capacitor at 5V and GND ? Perhaps that is needed if the power supply has a high frequency noise.
How is the ATmega8 connected ? The Aref should not be connected (or only with a 100nF).
Both Vcc and AVcc must be connected to 5V.
http://arduino.cc/en/Hacking/PinMapping
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 40
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have no I idea why it's not booting. The Atmega is wired just like this(without the programmer attached):
http://arduino.cc/en/uploads/Tutorial/ArduinoUSBSerial.png

I made another barebones circuit with blink example, and got same resoults. I tried to swap the MCU to see if that was somehow damaged, but I got same resoults with another chip too.
I tried 100nF cap, attached and unattached Aref. Same resoults.
Logged

Offline Offline
Edison Member
*
Karma: 36
Posts: 1219
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

First of all, the breadboards have sometimes bad contacts. You will find all kind of problems with those on this forum.

Using a led and resistor is the most simple, let's first try to make that work.

There should be very short wires to the X-tal and the 22pF and to GND.
And a 100nF from Vcc to GND.
Do you have a multimeter to measure the 5V ? If it is a (bad) USB power, it could be below 4.5V.

If it still doesn't work, can you make a photo of it ?

Logged

NSW Australia
Offline Offline
Faraday Member
**
Karma: 93
Posts: 3716
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

First of all, the breadboards have sometimes bad contacts. You will find all kind of problems with those on this forum.
And ...

There should be very short wires to the X-tal and the 22pF and to GND.
So these should be on the same breadboard rows as the chip pins themselves.

And a 100nF from Vcc to GND.
- everywhere - so on each side of the chip where Vcc and ground connect, and a couple on the power rails for good measure.  Add a 10µF or 47µF electrolytic as well.  This is a very common "Wow!  It works now!" event here.  We are talking about devices that operate at radio frequencies, leads have inductance.

Check that if you are using a MB102 style breadboard, the power rails are continuous from one half to the other if you are using both ends.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Maybe you should wait for 5-10 secs. It also happens to me, i am using atmega8A-16PU.
Voltage is at 5V (from USB) and using 16MHz crystall and bootloaded with
../arduino/bootloaders/atmega8/ATmegaBOOT-prod-firmware-2009-11-07.hex

Right after the successful upload, it takes 5-10secs to blink the pin13 led.
That tells the arduino is running.
Logged

Pages: [1]   Go Up
Jump to: