Pages: [1]   Go Down
Author Topic: Display lcd HD74480 2x16  (Read 3592 times)
0 Members and 1 Guest are viewing this topic.
Milazzo (ME)
Offline Offline
Sr. Member
****
Karma: 0
Posts: 395
Chi cerca trova. .
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Salve a tutti oggi mi è arrivato un display lcd con cip HD74480 ho collegato correttamente tutti i pin all'arduino (dopo aver caricato l'esempio "hello, world" solo che c'è un piccolo problema, non funziona. Il display non visualizza nulla, ho provato a modificare il contrasto tramite il pin Vs.
Avete qualche consiglio?
Logged

Xfox's Blog, Elettronica, informatica e tant'altro: http://www.xfox.it

Milano, Italy
Offline Offline
Faraday Member
**
Karma: 10
Posts: 3085
Sideralis Arduino!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Ho utilizzato tante volte il display col chipset in questione ma da tanto tempo non lo uso + con la modalita "mille pin da arduino" che comunque rimane il modo piu' pratico di provarlo le prime volte. Ricontrolla i cavi, che siano dentro bene nella board e ricontrolla con un trimmer e pazienza il contrasto, potrebbe essere che non arrivi al punto che ti serve per vedere le lettere. Dovresti riuscire ALMENO a vedere dei quadrati e girando il tuo trimmer piano piano a parificarli con lo sfondo (punto in cui dovresti leggere qualcosa). Hai attivato anche la retroilluminazione? (Per un primo test puoi alimentarla con una piccola resistenza dal +5)

Fede
Logged

Federico - Sideralis
Arduino &C: http://www.sideralis.org
Foto: http://blackman.amicofigo.com

Milazzo (ME)
Offline Offline
Sr. Member
****
Karma: 0
Posts: 395
Chi cerca trova. .
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Gli unici pin lasciati scollegati sono i 4 dei dati (perchè ne uso solo 4) e gli ultimi due ovvero "Anodo" e "Catodo".
Ma comunque non vedo neanche i quadratini. I fili li ho ricontrollati un mucchio di volte, tutti inseriti correttamente!
Logged

Xfox's Blog, Elettronica, informatica e tant'altro: http://www.xfox.it

Milano, Italy
Offline Offline
Faraday Member
**
Karma: 10
Posts: 3085
Sideralis Arduino!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Scusa ma se non collegi Anodo e Catodo (A volte segnati con A e K) non si accendera' neanche il display...
Inoltre come hai collegato il trimmer per il contrasto?
Fede
Logged

Federico - Sideralis
Arduino &C: http://www.sideralis.org
Foto: http://blackman.amicofigo.com

Milazzo (ME)
Offline Offline
Sr. Member
****
Karma: 0
Posts: 395
Chi cerca trova. .
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Ti dirò, si accende il display, già solo quando collego Vss e Vcc. Come dovrei collegare anodo e catodo? (tramite resistenza?).
Comunque il trimmer l'ho collegato come partitore, i due pin esterni a +Vcc e GND e il pin centrale al pin di controllo luminosità.
Logged

Xfox's Blog, Elettronica, informatica e tant'altro: http://www.xfox.it

Milano, Italy
Offline Offline
Faraday Member
**
Karma: 10
Posts: 3085
Sideralis Arduino!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Anodo e Catodo sono quindi la retroilluminazione. Collegala con una resistenza da 1k (o quello che hai sotto mano) anodo a +5 e catodo a gnd. In realta' dovresti avere gia' dei risultati piu' o meno schifosi anche col setup che hai gia' adesso... Da quanto e' il trimmer?

Segui questo schema giusto?
Logged

Federico - Sideralis
Arduino &C: http://www.sideralis.org
Foto: http://blackman.amicofigo.com

Milazzo (ME)
Offline Offline
Sr. Member
****
Karma: 0
Posts: 395
Chi cerca trova. .
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Io ho seguito proprio questo schema! Il trimmer è da 10Kohm!
Comunque non funziona neanche collegando anodo e catodo! (Comunque la retroilluminazione si accende anche se non collego anodo e catodo)
Logged

Xfox's Blog, Elettronica, informatica e tant'altro: http://www.xfox.it

Milazzo (ME)
Offline Offline
Sr. Member
****
Karma: 0
Posts: 395
Chi cerca trova. .
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Nessun aiuto? smiley-sad
Logged

Xfox's Blog, Elettronica, informatica e tant'altro: http://www.xfox.it

Riva del Garda, TN / Forlì
Offline Offline
Edison Member
*
Karma: 7
Posts: 2247
Il piu' modesto al mondo
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

secondo me hai collegato solo anodo e katodo e non VCC e VSS perchè altrimenti non si illuminerebbe, poi ricorda che anche se è collegato all'alimentazione finchè non inizializzi il display e invii un dato non succede niente, poi collega prima il display e poi accendi arduino (o resettalo).

piccole accortezze ma pochi le seguono..
Logged

Il nuovo forum italiano sull'elettronica: http://www.electroit.tk/ <--- Nuovamente online!

Milazzo (ME)
Offline Offline
Sr. Member
****
Karma: 0
Posts: 395
Chi cerca trova. .
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Ho seguito questo post: http://www.arduino.cc/en/Tutorial/LiquidCrystal
E ho collegato tutto come da schema! Ho pure controllato più volte. Ho provato pure a inviare il programma di esempio con i comandi Display() e noDisplay() e mi accorgo che il display, più o meno, lampeggia.
Ho riprovato poi a caricare nuovamente l'esempio "Hello, world" ma nulla.
Il display si trova su futura elettronica cercando questo codice: 1446-ATM1602B
Logged

Xfox's Blog, Elettronica, informatica e tant'altro: http://www.xfox.it

L'Aquila
Offline Offline
Newbie
*
Karma: 0
Posts: 26
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Prova a dare un occhio al mio test:
http://www.tessitoreluigi.it/index.php?option=com_content&view=article&id=39:usare-un-potenziometro-come-selettore&catid=31:arduino&Itemid=28

Forse ti può essere di aiuto.
Ciao
Logged

Milazzo (ME)
Offline Offline
Sr. Member
****
Karma: 0
Posts: 395
Chi cerca trova. .
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Se io collego gli ultimi due pin come hai fatto tu il display si spegne, o meglio, porta la sua luminosità a zero e non me la fa ne aumentare ne diminuire
Logged

Xfox's Blog, Elettronica, informatica e tant'altro: http://www.xfox.it

Milazzo (ME)
Offline Offline
Sr. Member
****
Karma: 0
Posts: 395
Chi cerca trova. .
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Risolto tutto grazie, i fili non erano collegati in maniera esatta.
Logged

Xfox's Blog, Elettronica, informatica e tant'altro: http://www.xfox.it

Milano, Italy
Offline Offline
Faraday Member
**
Karma: 10
Posts: 3085
Sideralis Arduino!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

TE LO AVEVAMO DEttO !!!  smiley-cool smiley-cool
Logged

Federico - Sideralis
Arduino &C: http://www.sideralis.org
Foto: http://blackman.amicofigo.com

BZ (I)
Offline Offline
Brattain Member
*****
Karma: 235
Posts: 20230
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ciao Xfox
I pin dei display col controller HD44780 o equivalenti non sono sempre uguali. Cambia in numero di pin ( da 14 a 16) e la direzione di conta ( dx a sx o viceversa)
Devi stare attento e prendere informazioni dai dati tecnici del display che hai in possesso.
Ciao Uwe
Logged

Pages: [1]   Go Up
Jump to: