Go Down

Topic: Arduino on Xcode Project — Official Thread (Read 153 times) previous topic - next topic

ScottG


Can you try on your Mac hard disk instead?

Running embedxcode from terminal works if the project is on my local hard drive.

ScottG

I'm getting a couple errors after my first Build on a new project.  The build is successful, so I don't know if these errors are important are not.  They are:

/bin/sh: /usr/local/bin/wget: No such file or directory

Command /Applications/Xcode.app/Contents/Developer/usr/bin/make emitted errors but did not return a nonzero exit code to indicate failure

See attached screenshots and log

avenue33


I'm getting a couple errors after my first Build on a new project.  The build is successful, so I don't know if these errors are important are not.  They are:

/bin/sh: /usr/local/bin/wget: No such file or directory

Command /Applications/Xcode.app/Contents/Developer/usr/bin/make emitted errors but did not return a nonzero exit code to indicate failure


No, it isn't a problem. embedXcode is just checking the release number.

ScottG



I'm getting a couple errors after my first Build on a new project.  The build is successful, so I don't know if these errors are important are not.  They are:

/bin/sh: /usr/local/bin/wget: No such file or directory

Command /Applications/Xcode.app/Contents/Developer/usr/bin/make emitted errors but did not return a nonzero exit code to indicate failure


No, it isn't a problem. embedXcode is just checking the release number.


What's strange is I just ran Build on a project I created a couple days ago, I think it was with embedXcode Release 39, and I don't get those errors.  Any idea why?

avenue33

#314
Apr 19, 2013, 02:22 pm Last Edit: May 10, 2013, 06:25 pm by avenue33 Reason: 1
The new release of the template only applies for the new projects.

You need to copy-paste the makefiles, About and Utilities folder from the template into your existing project.

Go Up