Go Down

Topic: How to disable autoreset on Arduino NANO v3? (Read 1 time) previous topic - next topic

simoleso

Hi, recently I've used some Arduino Nano v3 for some projects but I've encountered a problem that I was unable to solve: when, from Windows 7, a program (the Arduino IDE or a python script) begins a connection with the arduino USB the board reboots.

Usually with Arduino UNO and 2009 I solved this problem putting a 120Ω resistor between +5V and RST pin, like explained here, but this workaround doesn't work with Nano V3: is it this a normal behavior?

Someone else faced the same problem and solved it?

Thanks for your attention,

Simone

DrAzzy

10uF cap between Rst and Gnd is the recommended way to temporarily disable autoreset.

The 120 ohm resistor may work in some circumstances, but doesn't guarantee disabling it - not without making assumptions about the strength of the driver on the DTR pin of the serial adapter!
ATtiny core for 841+1634+828 and x313/x4/x5/x61/x7/x8 series Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts (some assembled), mosfets and awesome prototyping board in my store http://tindie.com/stores/DrAzzy

ron_sutherland

#2
Sep 14, 2017, 10:01 pm Last Edit: Sep 14, 2017, 10:07 pm by ron_sutherland
I use an external serial connection without the DTR line connected.

On a an Uno I can disable the ATmega16u2 with a jumper on the chips programming header (e.g. reset pin to ground pin) and then connect an external serial bridge (i.e. this also drops power usage from 50mA to 30mA).

The [Nano] is showing a FTDI based serial bridge, so it would need one of those hacks that I do not do to disable.

[Nano]: https://www.arduino.cc/en/uploads/Main/Arduino_Nano-Rev3.2-SCH.pdf

I used the FT232RL on a few version of my project boards but found the FT231XS cost less and worked as needed. Anyway, my recollection is the FTDI pins are held high when the USB data pins have not seen a host. They are connected to the ATmega328p through 1k Ohm. The external serial device (FTDI friend) was able to pull up/down those MCU pins without any interference from the FTDI on my board (and the MCU did not reset). 

At this time I would probably go with a CP2104 or an FT231XS based board https://www.adafruit.com/product/3309

simoleso

I've founded a rough solution to my problem: as explained here, there is a 100nF capacitor connected to the CH340G DTR pin, this capacitor is shown here.
I've simply desoldered this capacitor (with a cutter) and now the Arduino Nano won't reset during USB connection anymore.

Due to load a new sketch, I've to push the physical reset button when the Arduino IDE start uploading the new firmware, so the board reboot and the bootloader wait for a new firmware.

Simple. Barbaric. But it works.

MasterMark2017

Sorry to jump in guy but Just wondering if its this thats causing my prob
im using a .bat to simple turn on/off a led but when i plug in my Arduino into the usb it wont work on the first double click BUT works on the second double click ??
Would this be the reason

Go Up