Go Down

Topic: Toasted ST7920? (Read 2465 times) previous topic - next topic

mrquesito

Hello,

A few days ago I bought a ST7920 128x64 screen (http://www.allshore.com/pdf/Sitronix_ST7920V33.pdf   http://www.satistronics.com/myfiles/file/LCD/YB12864ZB.pdf), Arduino compatible. I've got all the libraries and stuff, everything works correctly on my computer, but when I tried it with Arduino, there was motion (it was supposed to be), but it was kind of messy. I tried connecting it both in parallel and serial, but I only could make it "work" in parallel mode. Afterwards, I looked more carefully at the datasheet, and found the Reset pin, that I had left unconnected. I put it to GND, since it's the value it is supposed to have, but then I put it into 5V, trying to make the screen reset. The problem was that since that moment, the screen doesn't work anymore.
If I've broken somthing, could it have been a fuse? Maybe with a steady hand I could resolder a new one again...

Thank you,

Juan

mrquesito

#1
Jan 27, 2011, 10:17 pm Last Edit: Jan 27, 2011, 10:19 pm by mrquesito Reason: 1
I had already done those steps before, but I've done it again, and the screen is still blank. However, I've looked for "Reset" through the datasheet (the one in whose URL "Sitronix" appears), and in page 37 I found an interesting graph...  Unluckily, I can't understand its consequences :/

Thanks

mrquesito

I'm sorry, I've realized that the shop where I bought the display made an error, and they sold me a KS0108. Since the pin configuration is similar, I haven't toasted anything, so problem solved.

Go Up