Go Down

Topic: Trouble uploading to Pro Mini 5V (Read 474 times) previous topic - next topic

Aug 11, 2011, 11:59 pm Last Edit: Aug 12, 2011, 12:01 am by jtavrisov Reason: 1
So first off I cant upload to the Pro Mini 5V, I am using sparkfun's FTDI basic to do it. The RX/TX pins light up initially and the pro mini's red power LED lights up as well. After a while the IDE spits out an out of sync error.

Secondly the microcontroller on the pro mini gets kinda warm, its pretty worrysome. I'm just about finished with my project (been using uno to prototype) and running out of time. Have I destroyed the pro mini?

I've tried a couple things like putting a jumper between the RX/TX pins on the ftdi and verifying I get back what i sent ( I did). I tried burning the bootloader using the uno as per another topic and I got errors that way too (i think it was some kind of device error). At first I thought i was bad connections but now I've gone ahead and soldered pins to it and I still have the same issue. Also I'm sure the COM ports and devices are all correct. Ive tried a couple devices when uploading and still get the same issue.

CrossRoads

Is there a chance you are plugging the FTDI module on backwards?
That would ground the TX output line while putting 5V on RX input, atmega may not like that.

If the ATMega gets warm, that's usually a sign that its gone bad, at least an output pin or 2 got fried.

I just got a hot air work station, I have 2 prominis that I killed with accidental shorts (loose wire touched something it shouldn't have during debug, and another just up & died, might have been fried over the serial port as the device it was connected to was also damaged), gonna see if I can remove & replace.

I used an FTDI basic to program about 15 prominis for a bunch of boxes I built, both were very reliable.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

Sigh I figured it was gone. I wonder what i did to burn it out. I wonder if my university has any rework stations to replace the chip lol.

Theres no way I plugged in in backwards that many times, the GRN/BLK indicators seem pretty foolproof.

Go Up