Go Down

Topic: Could not initialize class gnu.io.RXTXCommDriver... (Read 5 times) previous topic - next topic

RoyK

OS: Windows 7 Ultimate (64 bit)

History: Have been using IDE Version 16. Yesterday upgraded to Version 22. Everything worked fine. Loaded and compiled the rather large sketch I have been working on, uploaded to the Mega board, ran. No problems.

This morning I rebooted the machine and when I load the sketch I get the following error (in the first window that opens when you start the IDE):

java.lang.NoClassDefFoundError: Could not initialize class gnu.io.RXTXCommDriver thrown while loading gnu.io.RXTXCommDriver

When I try to compile the sketch I get a Compile Error and garbage in the lower window.

Everything works just fine still in Version 16.

I suspect I need to change versions of Java (I have the java folder in V16 renamed so it won't be used). Am I right and if so how do I do that?

RoyK

OK, uninstalled Java and installed latest version (V6 Update 23). No help.

RoyK

Got it working. But frustrated.

All my design projects are on my J: drive -- including all my Arduino IDE installs. If I install V22 on my J: drive it doesn't work. However if I install it on my C: (boot drive) its working fine. Disk check of J: reveals no problems.

Frustrating. I hate computers & OSs sometimes...

Go Up
 

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.
Name:
Email:

shortcuts: alt+s submit/post or alt+p preview