Go Down

Topic: Bridge isn't work after some hours (Read 361 times) previous topic - next topic

fluke_df

Hello,

I was working in project with Arduino Yun, for send data to server.
I use expander ports with I2C and Python inside linino, for almost two days was working so good, but after some hours left to upload new data. When I saw that, I try to connect with console but I can't.

The two way's for work again it's with commands reset-mcu and reboot.

The idea it need works alone for send data to server for all year.

I hope someone help me for solve this problem or with ideas for make tests.
Ansioso de aprender

DarkSabre

One of my Yun installations became problematic after about a year where similarly the bridge would start going down every couple days or so.

As you noted, reset-mcu and reboot will get things back up and running.

The process I'm monitoring is down every day for about an hour between shifts, so I just schedule the arduino to reboot at that time every day using cron.

crontab -e
Code: [Select]
0 3 * * * /sbin/reboot
10 3 * * * /usr/bin/reset-mcu


If having it down for a couple minutes is an option for you, it seems to have worked pretty solidly for me so far. (reboots linux at 3:00am and reboots the sketch at 3:10am in my example)

fluke_df

#2
Sep 25, 2017, 03:13 pm Last Edit: Sep 27, 2017, 01:49 pm by fluke_df
Wow DarkSabre you are a genius, I made test with your suggestion and it wasn't stopped, it's working until today.

Really thanks a lot.  :)
Ansioso de aprender

Go Up