Go Down

Topic: arduino tools-serial menu item disabled (Read 12962 times) previous topic - next topic


Guys i am using arduino ide on ubuntu 8.10, I want to set the ide serial port to ttyUSB0,but the serial menu item is disabled, can anyone tell how i can enable it


Its disabled when there aren't serial ports available
My website: http://ried.cl


Hi ecopolis,

Try searching this forum. A number of people have had problems/queries about using arduino with Ubuntu 8.10.

If none of the suggestions work then please post again and I'll see what I can do to help as I'm successfully using Ubuntu 8.10 64 bits.




Hey Veronica,

How did you work this out?
I'm using Ubuntu 9.1 but on my IDE Serial Port is disabled!!! :-(
Could you work this out?


It often depends on where you install the IDE.  It works best when its installed in your home folder, and it usully needs the computer restarting after installation before it works properly.


I've installed the Arduido IDE thru the apt-get comand
Everything went fine..I can open up sketches, but the Serial Ports port cannot be selected...Sad!

I've rebooted it a few times... no success...:-(


What is your serial port? an USB port or a real serial port? can you see the device under /dev/ ?


This may be a slightly off-the-wall suggestion, but ...

Are you comfortable compiling C?

Tod E Kurt has a little program to open a serial connection (over USB) to an Arduino at

If you can, download, compile and run it, you should see the Tx and Rx LEDs flash if you run the program, and find the name of the correct /dev/ to connect to the Arduino.

If there is a /dev/ name that looks correct, and this program flashes the Tx/Rx LEDs, then the drivers are likely to be correct.

Just a thought.


Hello Ray,

I have a HP DV 9000 notebook and I'm was comfotable with the "apt-get install" Arduino and all the libraries

Under /dev/ there are many tty, but when I "ls" I see many tty's port but no ttyUSB! It seems my Ubuntu Serial Ports are stuffed somehow...

Any extra hint?


The ttyUSBx ports are only there when the arduino is plugged in, have you tried another USB lead ?


Still... even when it's plugged... nothing under /dev/
The only usb references under /dev/  are:

usbmon0, usbmon1 and usbmon2 :-[

I have tty from 0 thru 60 and ttyS0, ttyS1, ttyS2 and ttyS3 (and all other ports that are not really related to this issue)

I have tried all my USB ports physical ports, but no sucess...


May I just ask, is the FTDI USB driver installed?

Have you a friend with a working Arduino? So you can test your install?
Or someone with a machine you could install the FTDI driver and Arduino IDE to test the hardware?
At least divide and hopefully conquer the problem.

I must admit, if the LEDs come on, then the Arduino is probably working. Do the LEDs come on?


The arduino lights up fine.
I can push the sketch from my Mac ( at the office) into my Arduino, but when I try to do the same on my notebook Ubuntu 9.1 the Arduino runs fine...but I cannot upload a different sketch to it

The Tools>Serial Port is disabled in the IDE ;)


The times I have seen this (though I haven't seen lots of problems with Linux's)
were when kernel support for serial devices had been removed.

Does this sound at all feasible? Do you build your own kernels?


No! I don't build my own kernel
I downloaded the ISO image from the Ubuntu 9.1 version avalible on the site.
The only extra is that this time I went for the 64 bits!

Go Up