Go Down

Topic: MKR SD proto shield with SD library - partition not recognised (Read 416 times) previous topic - next topic

m1ketayl0r

Hi there,

Has anyone managed to get an SD card working using an MKR1000 with an MKR SD proto shield?

I'm using this SD card, and I've formatted it using "SD formatter" (as advised in the sticky post on this forum) using "Overwrite format", and just using the standard "CardInfo" example from the SD library, with no changes.

I can't find any examples anywhere that use the MKR SD proto shield, so I'm assuming that chipSelect should be left as pin 4. With this setting, the card is recognised as "SD2" but I get the following output in Serial monitor:

Code: [Select]
Initializing SD card...Wiring is correct and a card is present.

Card type: SD2
Could not find FAT16/FAT32 partition.
Make sure you've formatted the card


I found this topic which suggests that the GND pin in the SD slot isn't connected properly, but surely these shields don't ship with the need to manually connect up those pins like that?

Might it be an incompatible SD card? Has anyone got suggestions for cards that definitely work with the MKR SD proto shield?

Very new to all this, so please be gentle with me!

m1ketayl0r

Got a response from Arduino support - the batch of SD proto shields in the Arduino store I bought was faulty. They've refunded my order and are in the process of changing them, so it was an issue with the shield itself.

Thanks

Mike

ardiri

is this still an issue? just ordered two SD proto shields and getting the same issue.
// Aaron Ardiri
independent IoT consultant

Go Up