Go Down

Topic: Sparkfun Serial Motor Driver (Read 3 times) previous topic - next topic

MobileWill

http://www.sparkfun.com/products/9571

For the life of me I can't get this thing to work. I reloaded the firmware since it would just turn on and both stat LED's would be lit. No matter what I do it won't turn the motors on.

I have it at 115200 and nothing. I get a ready on startup too. Whenever I send a command I get the command echoed back on the serial.

Even if I make the command too long, whatever I sent gets echoed back.

I am running a Arduino Mega and the motors have been tested.

Anyone have experience with this controller?
Current Projects:                    Arduinos:
Security Robot Tank               Uno
Security Robot II 4WD            Mega2560

http://mobilewill.blogspot.com

bld

I got the same experience with it as you do... And finally when I got it working, it kept shutting off because of the short initial current the motors draw.

Instead I changed to this http://www.seeedstudio.com/depot/l298-dual-hbridge-motor-driver-p-284.html
captain-slow.dk | non contagious!

MobileWill

#2
Jan 27, 2011, 08:28 pm Last Edit: Jan 27, 2011, 08:31 pm by MobileWill Reason: 1
Thanks, how did you get it to work? I changed the limit in the firmware to 3.5 so I think if I get it to work it will stay working.

Thanks for the link, i think i saw that somewhere in my searches. That would be a last resort. How do you control that one?


I think I will read the firmware some more and see if I can't figure it out. Sparkfun support hasn't responded yet.

I wish it had a connection for separate motor power too. I would rather run the motors at 3.7 from my battery.

BTW how is their shipping times? I am in CA.
Current Projects:                    Arduinos:
Security Robot Tank               Uno
Security Robot II 4WD            Mega2560

http://mobilewill.blogspot.com

bld


Thanks, how did you get it to work?
I didn't ;) I messed around with it for some hours, then threw it away.

I don't know how long it takes to your place, but from seeedstudio and to me (DK), it takes between 2 and 3 weeks, but a lot of that is also customs.

To control the motor driver I posted a link to, you use 4 digital pins to set the direction each motor will go, and then a PWM for each of them to set the speed they should run at.
captain-slow.dk | non contagious!

MobileWill

Wow that uses a lot of PINS? Hmm I have a mega, I might have enough PWM pins, only using 2 for servos.

I think I can get it faster from robotshop as I am in the states.

Plus I need a good regulator... hmm. Thanks. I hate to throw it out, maybe re purpose it.

I will fiddle with it some more tonight. Did yours echo back what cmd you sent it?

Current Projects:                    Arduinos:
Security Robot Tank               Uno
Security Robot II 4WD            Mega2560

http://mobilewill.blogspot.com

Go Up