Go Down

Topic: graphical lcd (nokia 3310) (Read 9759 times) previous topic - next topic

mikalhart

#30
Oct 06, 2008, 04:27 am Last Edit: Oct 06, 2008, 04:42 am by mikalhart Reason: 1
Yup.  You just need to cast your (character) string to a byte string like this:

LcdStr(1, (byte *)"ok");


kuk-- I might suggest a slight modification to LcdStr as follows, since probably many people would use that to print static (char) strings, right?

Code: [Select]
void LcdStr (int size, const char *dataPtr )
{
 while ( *dataPtr )
 {
   LcdChr( size, (byte)*dataPtr++ );
 }
}


Mikal

The_Bongmaster

hi i'm having no luck with this lcd :S
i used kuk's code and the stuff on the playground linky and nothing is showing up on the screen :(
the screen is fresh out of a 3310, and was functioning fine, has only been powered from a 3.3v run RBBB and all soldering is good..

anyone know why i am getting nothing? screen should be working perfectly :S
B-dui in creation.

gbpic

What's on your VOUT from the LCD? I needed to have a 4.7uf capacitor on mine for it to work. (though if it was disconnected entirely it did work somewhat)

Vout -----Cap-----Gnd

dimas

Hi all, I've got this lcd working using schematics and demo code from nuelectronics' Nokia 3310 LCD shield v1.0. Now I have one question and one problem.
The question is that in this thread is duscussed how to properly set i/o signals to 3.3v level. The nuelectronics' schematic does not use any level shifts and there is note on schematic saying "VCC -3.3V - 5V  All logic I/O compatible with 5V & 3.3V logic level". I've powered my lcd direct from 5v line from Arduino board and no level shifts on i/o lines. And everything worked. How could you explain this differencies?
Everything worked until I started to move SPI SS signal from default PB2 pin to PD6 pin (as I want to add SD-shield later where SS pin to PB2 is hardwired). The problem that characters are output turned up side down or mirror reflected against vertical axis. I have not figured it out yet which code modification gives either view but it always screwed somehow. I have read many threads like "two SPI devices on a bus" on the forum and tried few suggestions from there without further progress on the output. What may cause such a behaviour of the lcd?
Thanks in advance.

dimas

Updates: mirror reflectance was my mistake - left test changes. Characters turned half round - suppose some bugs in initialization.
Now display is working, will try to figure what changes were so critical.

Crook

I'm trying to get this LCD screen working too, and no joy. Is there a way I can test my screen besides getting it to actually work? Something like getting it to scan all black?

I think I've got everything connected right, but without it working I can't be sure. This link in the playground http://www.arduino.cc/playground/Code/PCD8544 mentions 5 pins, 3.3v and ground and no other electronics. Does this mean a cap is not needed on the VOUT pin 7? I've tried with and without a cap (10uf) and nothing either way.

3D Artist,Modeler, Texturer, Animator, Electronics and Robotics, Programming C, VB, Website Design, Flash animator

Too many hobbies?

Nyo

some news regarding this lcd using playground directions?

jaz neeraj

could any one post complete program and the circuit diagram for interfacing here???

i want to put this display in my car....!! :) :) :)

Go Up