Go Down

Topic: ATMega 1280 Linux Connection Problem (Read 21609 times) previous topic - next topic


Jan 27, 2011, 06:06 am Last Edit: Jan 27, 2011, 06:11 am by mrtaylor Reason: 1
close the terminal and open a new one

Is you window manager kde? if so :
cd  to the arduino directory
kdesu ./arduino


It looks like he is using it on the kernel console i.e. no GUI.
Type startx
Avoid throwing electronics out as you or someone else might need them for parts or use.
Solid state rectifiers are the only REAL rectifiers.
Resistors for LEDS!


Ok, in a terminal in X, type:
sudo su
Enter the password if prompted. Now you should be in a root environment with the root profile. Now try typing arduino to start the IDE and see what happens.



Jan 27, 2011, 07:25 am Last Edit: Jan 27, 2011, 07:28 am by reprapperMC Reason: 1
mrtaylor: I am using KDE. 'kdesu ./arduino' gives no output. I ran './arduino' after and still no rxtx lights and the same avrdude error.

smeezekitty: 'startx' gives:
Code: [Select]
steven@linux-ov9v:~> startx
xauth:  creating new authority file /home/steven/.serverauth.6193

Fatal server error:
Server is already active for display 0
       If this server is no longer running, remove /tmp/.X0-lock
       and start again.

Please consult the The X.Org Foundation support
        at http://wiki.x.org
for help.

No protocol specified
giving up.                                                                            
xinit:  Resource temporarily unavailable (errno 11):  unable to connect to X server    
xinit:  No such process (errno 3):  Server error.

Igor86: I'm not sure what you mean by a terminal in X. I'm using the  terminal found in the favorites (Konsole).
Code: [Select]
steven@linux-ov9v:~> sudo su
root's password:
linux-ov9v:/home/steven # cd /home/steven/bin/arduino-0022
linux-ov9v:/home/steven/bin/arduino-0022 # ./arduino
Exception in thread "main" java.lang.ExceptionInInitializerError
       at processing.app.Base.main(Base.java:112)
Caused by: java.awt.HeadlessException:
No X11 DISPLAY variable was set, but this program performed an operation which requires it.
       at sun.awt.HeadlessToolkit.getMenuShortcutKeyMask(HeadlessToolkit.java:231)
       at processing.core.PApplet.<clinit>(Unknown Source)
       ... 1 more


Whats happening is that the DISPLAY environment variable (ans probably others) are not getting set correctly for the root account so that it doesn't give you acces to the display to open the arduino IDE window.

Try this:
xhost +localhost
xhost +root
sudo su
enter password

If that does not work (some xhost implementations do not accept usernames anymore, only hosts), then you must give us some more details about the system. Do you login from the console then start X windows by startx? Do you login via login manager (graphical login)? In any case, login as root and then do the same as you would as a normal user. I've never used SUSE linux so I have no idea how far it has deviated form the purist linux distros such as Arch or Slackware and so I don't know what access mechanisms it uses.

Hopefully some of this advice will bring you closer...


Its a long time since I used Linux and I wonder what this does:
Code: [Select]

xhost +localhost
xhost +root
Avoid throwing electronics out as you or someone else might need them for parts or use.
Solid state rectifiers are the only REAL rectifiers.
Resistors for LEDS!


xhost allows for rudimentary access control to the X server. xhost +domain/username allows access to the X server to the specified domain/username.

man xhost:
Code: [Select]


      The xhost program is used to add and delete host names or user names to
      the list allowed to make connections to the X server.  In the  case  of
      hosts,  this  provides  a rudimentary form of privacy control and secu-
      rity.  It is only sufficient for a workstation (single  user)  environ-
      ment,  although  it  does  limit  the worst abuses.  Environments which
      require more sophisticated measures  should  implement  the  user-based
      mechanism  or use the hooks in the protocol for passing other authenti-
      cation data to the server.



Ok, I got the mega connecting however I found no fix for openSUSE. I even tried doing a fresh install of openSUSE 11.2 rather than 11.3 and continued to get the same errors. So, I did a fresh install of Ubuntu 10.04 and installed Arduino IDE according to the Arduino directions and it worked perfect. I can load programs and connect to the Reprap Repsnapper software with ease.

Go Up