Go Down

Topic: Cant upload my projects (Read 3232 times) previous topic - next topic

benb

Sep 29, 2017, 09:57 pm Last Edit: Sep 29, 2017, 11:11 pm by benb
Hello and servus,

as I mentioned I have several problems with the online project hub:

First I am not able to connect to my Arduino Due or my Nano. There is simply an red x in front of the selected board. No clue whats wrong or what I should do. Both boards are supported by my mac and the offline Arduino IDE.
**Edit** Fixed that by installing "ArduinoCreateAgent-1.1-osx-installer.app"
I found the info in the tutorial. It was not mentioned by the online hub itself.

Second, I cannot upload my sketches compressed as zip file. These are several projects plus some external libs. Error message says: "Error while importing a sketch
An error occurred while importing the sketch. Please make sure the file is not corrupted."
I used the build in compress file dialog in macos. I tried also only to upload my projects without the libs. Same result.

I put the Arduino.zip in the attachment, so everybody is able to reproduce this error. I'm using MacOS 10.13 and Chrome here.
**Edit** File to big, with 2 MB.

Another thing, not related to the online hub, is that I can not see the menu in the offline Arduino IDE, where I should able to select the different boards and some build in sketches. My version is 1.8.4 and was downloaded today.
**Edit** Error is known, a fix is in work: https://github.com/arduino/Arduino/issues/6548
Stays only the issue with the zip upload...

But thanks anyway for your great work! Arduino makes programming fun!

ballscrewbob

This section is for "PROJECT HUB"

It is quite different to CREATE which is the actual editor (ONLINE)

Also 1.8.4 usually refers to the installed (OFF LINE) version.

I am seeing a little confusion with 3 different things here that you might want to explain a little more in detail.

1. Are you trying to upload files to "PROJECT HUB" or "CREATE ?

2. Is the ONLINE EDITOR "CREATE" working for you ?

3. Do you also have the installed desktop version installed ? (you can run both without conflict)

Once I know exactly what you are doing I may be able to offer a little more assistance.

In case you are unsure what extra to write please take a look at this post.


It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

Go Up