Pages: 1 ... 16 17 [18] 19   Go Down
Author Topic: Sure Electronics new 32x16 bi-color display: 3216 RG -Cont. from read only forum  (Read 61260 times)
0 Members and 1 Guest are viewing this topic.
Stockholm
Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

- When I remove the usb my display garbles.  Video of error http://bit.ly/HF9DxV
I am experiencing this problem regardless of usb in or out.

Ive tried with a Arduino Uno Rev3, and Arduino Nano 3.0.

using the code from http://code.google.com/p/ht1632c/source/browse/

It seems like the upper left segment of the display to the right is a copy of lower right segment of the display to the left

Code:
so if this is a working display:
aabb1122
ccdd3344

then mine is like this:
aabbdd11
ccdd2233

images of the display running example sketches: geometry, line, fill and cirles:


any advice?

//eslin
« Last Edit: August 08, 2012, 05:05:20 pm by eslin » Logged

Transient Explorer
Offline Offline
Jr. Member
**
Karma: 0
Posts: 82
Arduino rocks (by default)
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Can you post the code you're using for one of those examples?
Logged

0
Offline Offline
Edison Member
*
Karma: 8
Posts: 1411
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Swap the displays. Do you get the same thing?
Logged

Stockholm
Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Can you post the code you're using for one of those examples?

Im running the examples without modification, Ive matched the pins and use the same on my Arduino Nano
http://code.google.com/p/ht1632c/source/browse/examples/geometry/geometry.pde
http://code.google.com/p/ht1632c/source/browse/examples/line/line.pde
http://code.google.com/p/ht1632c/source/browse/examples/fill/fill.pde
http://code.google.com/p/ht1632c/source/browse/examples/circles/circles.pde

Im pretty sure ive done it before with the same results, when this first happened I thought maybe one of the displays was broken, but I remember they show the same result in both configurations.
Will test to swap the displays and post results in a couple of hours.

Br
eslin
Logged

Stockholm
Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Swap the displays. Do you get the same thing?

Doh, they worked as expected when I swapped them, which make me remember that I only tested them individually before and not chanined in this way.

when swapping back they still show the problem, is this common? they aught to be the exact same panel and thus the result should be the same regardless of position.

Have you seen this before?

br
eslin
Logged

0
Offline Offline
Edison Member
*
Karma: 8
Posts: 1411
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Have you seen this before?
Yes. I don't have an explanation though.
Logged

Stockholm
Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Have you seen this before?
Yes. I don't have an explanation though.
Ive been planning to buy some more units and hook them up in a 64x32 configuration, then this could become a problem again I guess?

//eslin
Logged

0
Offline Offline
Edison Member
*
Karma: 8
Posts: 1411
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Of course.
You also need a good 5V power source capable of at least 3A. (Pololu has one.)
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 80
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi team, I have two Sure 3216 displays and there is no way to have them working OK.
I have tried several codes I found on the forum (and elsewhere) but there is allways something wrong with characters being displayed at the wrong position.

Can any of you tell me where can I find a simple code that works flowlessly with 2 displays?

I just want to be able to plot dots on a 32x32 matrix, no funcy graphics and/or characters, just dots!!!

Many thanks in advance for any kind of help...
Logged

Forum Administrator
MMX
Offline Offline
Edison Member
*****
Karma: 37
Posts: 1139
hallo kompis
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,

the issue with this displays is not that the code most people are using is wrong ... I got a couple of displays from a friend today and I had the same issues explained by @eslin. After reading the code and realizing there was nothing bad in it, I realized that the 74hc164 chip is sending the output from pin QD directly to CS_OUTPUT. This means there is no delay between CS_OUTPUT in one SURE display and the CS_INPUT in the next when you daisy chain the displays.

The proper way of doing this would have been if the manufacturer had used QE as the CS_OUTPUT. Once you have the display, there is actually a patch for this without cutting anything. I also realized that the capacitor C1 is not mounted on the board. Adding a 1nF capacitor there did the magic for me. It delayed the load of the CS_INPUT enough to stop the bug of happening.

/d

See the attached picture


* 20121028_170252.jpg (762.16 KB, 3264x2448 - viewed 99 times.)
Logged

0
Offline Offline
Edison Member
*
Karma: 8
Posts: 1411
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

This is what Don (a customer) said in an email regarding the same issue:
I did look at the clocking relationships on the scope.
The clock to data hold timing on the HC164 was marginal, 2ns, versus -2ns typical and 4ns minimum. Meaning it will probably work, but it's not certain. CLK, DATA and WR are buffered through 2 sections of an HC04, with a delay of 11ns, but CS_OUT is not, so with every successive board in a chain this timing degrades. They ran out of HC04 gates. Installing the 10pf capacitor at C1 might help, but it's not ideal.

Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 80
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks David and Florinc, i'm going to try your suggested solution and will post my findings.

Cheers!
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 80
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Dear David and Florinc, the missing 1nF on C1 was the problem, once I installed it as per David suggestion everything is working fine. Many thanks!

Worth to notice is the (ridiculous) message I got from Sure Electronics Customer Support when I asked them about David's suggestion:

Dear Sir,
Thank you for your purchase.
It can solve the problem by the way you said. The item has problem, we will update the version.
Have a nice day.
 
Best wishes,
Customer Service and Sales
Sure Electronics Co., Ltd.
East zone, 3F, Building 6   
Logged

Sunnyvale, CA
Offline Offline
Full Member
***
Karma: 0
Posts: 147
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey all, I'm surprised to see this thread still on the first page =).  I've been away, work has taken up most of my time, and I am getting laid off due to a reduction in force, but as soon as I get a new job I'll be revisiting this page, and continuing work on my bluetooth code.   Florinc, thanks for the nod on your site, just noticed it today.  I had issues with my circuits working 100% in the past (custom boards, had issues with usb working) but I'll be grabbing another arduino uno and working everything out again in to make sure everything works 100%.  I've also been busy on another android project for a client, but when that wraps up I'll work on my github repo to update all code/examples.

Glad to see the community is still active in this thread, take care all!
« Last Edit: January 03, 2013, 08:53:31 pm by evanrich » Logged

My first major project (looking for people who would like to help contribute) Bluetooth Sure 32x16 LED Displays!: https://github.com/evanric

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have to mention this, because I've been banging my head against this for days: The latest version(s) of this library will not work on the Arduino Leonardo! I have a Duemilanove and it works fine on that. Until the lightbulb popped up over my head and I decided to try it on the Duemilanove I was ready to pull out what little hair I have left!

Thanks very much for all the hard work put in by everyone here.
Logged

Pages: 1 ... 16 17 [18] 19   Go Up
Jump to: