Go Down

Topic: Help please. Error uploading to Arduino.. (Read 5 times) previous topic - next topic

vulrath

If you are using serial communication, then you can't use pins 0 and 1.  They're used in the background to talk to the computer.

David Canoe

I had the same problem with my Uno same sketch and same error codes.
I am running Vista sp2 on a toshiba laptop.

I solved the problem by logging as admin and all worked as it should.

The guess as to the reason why, Vista in their weird way prevents access to serial ports unless in admin as a security measure (by the way I just got rid of a nasty bit of adware(netbits) which came thru a user account so much for security)

vulrath

#7
Feb 01, 2011, 05:58 pm Last Edit: Feb 03, 2011, 01:47 am by vulrath Reason: 1
I seem to have also developed this problem (and on the eve of my greatest breakthroughs on my project, too).  I circumvented it by going back to the 0021 IDE and running it as Admin (still using the 0022 drivers, though).  Uploads every time now.

Strangest thing - worked fine for 2 months, until now.  All of my problems seem to have stemmed from switching to the 0022 drivers and IDE.
ETA: Ran 0022 as Admin, and uploaded just fine.

Go Up