Go Down

Topic: RF12 + SPI device (Read 2221 times) previous topic - next topic

Deanna

Hi all,

Regarding this post: http://arduino.cc/forum/index.php/topic,13555.0.html

I am interested if anyone has been able to make the rf12 radio work with a different chip select pin (than D10).. I hope to use the rf12 with a yellowjacket that hopefully doesn't have the same MISO glitch as the ethernet shields.

I have changed the

#define SS_PORT     PORTB
#define SS_BIT      2
#define SPI_SS      10   

code in RF12.cpp (http://jeelabs.net/projects/cafe/wiki/RF12) to

#define SS_PORT     PORTD
#define SS_BIT      3
#define SPI_SS      3

and the wiring to digital pin 3, and added pinMode(10,OUTPUT); to my code that was otherwise working, but have had no luck (on a few different pins). I added this because I have read that you must make SS an output for the Arduino to be a master - did I interpret this correctly?

My code is just this 'PingPong' demo code: http://jeelabs.net/projects/cafe/wiki/PingPong_sketch
How it behaves at the moment is the same as how it behaves if some of the wires have come loose - it just stops sending (which prevents it from receiving I believe, but regardless)

Is there something else that I should change in the hardware/software?

Thanks in advance!

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy