Go Down

Topic: Arduino Mega 2560 with possible bad USB chip (Read 5543 times) previous topic - next topic

aymerich

Hi,

I think I might have burnt the USB chip on Mega 2560.  Windows still recognizes the device(on COM12) but the IDE and terminal programs won't connect to that port.  The program I had loaded earlier still works.

I have tried changing the COM port and that didn't work.

It works with another 2560.

When I power it up the TX RX LEDs don't blink, but the power LED is on and LED 13 blinks twice.

Is it possible that it's only the bootloader?

If it is the USB chip, is there another way of programming it or do I just chalk it up to experience?

Aymeric

danielkuzmin


aymerich

I was testing a custom L293D motor shield and powering the whole thing through USB, I'm wondering if it didn't draw too much current.

Jeff K

You can test the USB interface by doing a loopback test.  Search the old forums for examples on how to do this.  Essentially you need to jumper digital pins 1 and 0 together.  Then open up the serial monitor.  Anything you type in there should be echoed back.  If this happens then the USB interface is most likely working correctly.
Jeff K - JKDevices.com - home of the MegaMini

aymerich

That won't work, I can't get a serial connection going on the computer side.  Windows 7 recognizes the arduino and assigns a COM port but no application I've tried establishes a serial connection to it.

Go Up