Go Down

Topic: Newbie needing some help (Read 75 times) previous topic - next topic

vmax100uk

Hi guys.
Ive just put this kit together and ive got a couple of problems.
http://www.robotpark.com/Robotpark-MF-70-CNC-Kit
A4988 DRIVER CNC SHIELD EXPANSION BOARD
A4988 STEPPER MOTOR DRIVER
All seems to be working ok apart from the Z axis needs to be inverted which i presume means i need to switch a couple of wires somewhere.
My main problem which ive googled to death is that when i use the manual x+ x- buttons the axis travels in the minus direction on both buttons and will not move in the plus direction.
Has anyone come acrosd this before. Please be gentle as im very new to hobby cnc stuff. :)

nathancamp

Every time that has happened to me, it has been a loose connection on the direction pin.

vmax100uk

Every time that has happened to me, it has been a loose connection on the direction pin.
Thanks for the tip. Is that one of the 4 pins that the stepper wires connect to on the board.

nathancamp

No, it is one of the connections between the arduino and the driver. You can check the voltage on that pin with a multimeter.

vmax100uk

No, it is one of the connections between the arduino and the driver. You can check the voltage on that pin with a multimeter.
Cheers mate, i will check that out. The control box came ready assembled with the kit so maybe it got a rough ridenin the postal system.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy